chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Florian Müller <f...@apache.org>
Subject Re: Connect to Sharepoint 2010 through CMIS Workbench
Date Fri, 08 Jun 2012 07:36:36 GMT
 Long time ago, I also got NTLM working. But I have to advise against 
 using it.
 Once in while, some CMIS operations just fail. Although you can repeat 
 the call and it works, it is difficult to implement a stable application 
 with this behavior.

 Use Basic Authentication over SSL if you can.


 Florian


> When we switched the auth type to standard and NOT NTLM on SP server
> configuration...we were able to connect the CMIS workbench to it and 
> see
> the list of repositories.  Otherwise we had the same issue...could 
> never
> get NTLM to work.
>
> Mark
>
> On Jun 7, 2012 4:35 PM, "Florian Müller" <fmui@apache.org> wrote:
>
>> Try playing with standard and NTLM authentication. It depends on 
>> your
>> SharePoint setup.
>>
>>
>> Florian
>>
>>
>> > I can get the repositories. But it fails on login with the error:
>> runtime: Error: The server sent HTTP status code 401: Unauthorized
>> >
>> > -----Message d'origine-----
>> > De : Florian Müller [mailto:fmui@apache.org]
>> > Envoyé : 7 juin 2012 16:10
>> > À : dev@chemistry.apache.org; Alexandru Deliu
>> > Objet : Re: Connect to Sharepoint 2010 through CMIS Workbench
>> >
>> > Hi Alex,
>> >
>> > Yes, that definitely works.
>> > What's the error message?
>> >
>> >
>> > Florian
>> >
>> >
>> >> Hello,
>> >>
>> >> Using OpenCMIS library I can connect by creating a session to
>> SharePoint 2010 repository, but not using if the CMIS Workbench. I 
>> would
>> like to know if the CMIS Workbench can be used to connect to 
>> SharePoint
>> 2010.
>> >>
>> >> Thanks!
>> >>
>> >> Alex.
>> >>
>> >>
>> >
>> >
>> >
>>
>>
>>
>>


Mime
View raw message