chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yannick Kirschhoffer (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CMIS-505) null children in Folder.getChildren() results
Date Sun, 19 Feb 2012 19:38:41 GMT

    [ https://issues.apache.org/jira/browse/CMIS-505?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13211504#comment-13211504
] 

Yannick Kirschhoffer commented on CMIS-505:
-------------------------------------------

I first assumed it would be related to the fact that I'm using PostgreSQL, but I tried with
a brand new repository on MySQL and had the same result.

I create a folder with 140 documents using OpenCMIS. The files show up fine in Share. But
if I list the folder using OpenCMIS using Folder.getChildren, I can read the first 100 children,
and then encounter a null reference...
                
> null children in Folder.getChildren() results
> ---------------------------------------------
>
>                 Key: CMIS-505
>                 URL: https://issues.apache.org/jira/browse/CMIS-505
>             Project: Chemistry
>          Issue Type: Bug
>          Components: opencmis-client
>    Affects Versions: OpenCMIS 0.6.0
>         Environment: Java SE 6 application running OpenCMIS 0.6.0 to communicate with
Alfresco Community repository.
>            Reporter: Yannick Kirschhoffer
>
> I happen to have some incomplete results and null pointers in Folder.getChildren() results...
This usualy happens on medium sized folders (around 200 entries).
> This happens while using Alfresco Community 4.0d, but does not seem to occur with 3.6d.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message