chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pankaj Tiwari <panky.tiw...@gmail.com>
Subject Re: Feature CMISProducer is not activated with SP 2010 server
Date Mon, 17 Oct 2011 13:27:59 GMT
Hi Florian,

The problem got resolved once i started using the hostname instead of
ip-address. The WSDL file has all the bindings with hostnames.
Is this a correct inference?

Thanks,
Pankaj


On Mon, Oct 17, 2011 at 4:09 PM, Florian Müller <
florian.mueller@alfresco.com> wrote:

> Hi Pankaj,
>
> I'm afraid the OpenCMIS configuration depends on your SharePoint
> configuration and therefore it is difficult to tell what's wrong here.
> For example, if you need the NTLM authentication provider or not depends on
> your IIS authentication configuration.
>
> This is obviously a server error message. There is not much we can do on
> the OpenCMIS side.
>
> Some general advice:
> - Make sure the username is correct. It might have to be prefixed with the
> domain name.
> - Make sure the WSDL is correct and doesn't point to a different server. If
> the host name in the WSDL is "localhost", change it to the name of the
> server.
> - You can also reference the WSDL directly (http://<host>/_vti_bin/CMISSoapwsdl.aspx)
> if you set up an Authenticator first (see [1]).
> - Check the repository id.
> - Try to connect with the CMIS Workbench [1]. There is a SharePoint
> configuration template in the Expert tab in the Login dialog.
>
>
> Florian
>
>
> [1] https://issues.apache.org/jira/browse/CMIS-423
> [2]
> http://chemistry.apache.org/java/developing/tools/dev-tools-workbench.html
>
>
>
> On 16/10/2011 21:01, Pankaj Tiwari wrote:
> > Hi,
> >
> > I am getting the following error when trying to communicate with
> Sharepoint
> > 2010 server.
> >
> > Exception in thread "main"
> >
> org.apache.chemistry.opencmis.commons.exceptions.CmisNotSupportedException:
> > Feature CMISProducer is not activated.
> >     at
> >
> org.apache.chemistry.opencmis.client.bindings.spi.webservices.AbstractWebServicesService.convertException(AbstractWebServicesService.java:109)
> >     at
> >
> org.apache.chemistry.opencmis.client.bindings.spi.webservices.RepositoryServiceImpl.getRepositoryInfo(RepositoryServiceImpl.java:90)
> >     at
> >
> org.apache.chemistry.opencmis.client.bindings.impl.RepositoryServiceImpl.getRepositoryInfo(RepositoryServiceImpl.java:69)
> >     at
> >
> org.apache.chemistry.opencmis.client.runtime.SessionImpl.connect(SessionImpl.java:610)
> >     at
> >
> org.apache.chemistry.opencmis.client.runtime.SessionFactoryImpl.createSession(SessionFactoryImpl.java:90)
> >     at
> >
> org.apache.chemistry.opencmis.client.runtime.SessionFactoryImpl.createSession(SessionFactoryImpl.java:64)
> >
> > 1. I have configured CMIS Producer as active in the site I am using. The
> > status shows as active
> > 2. I have a page with CMIS Consumer web part which displays the contents
> > successfully.
> > 3. The java program through which I am trying to communicate to SP 2010
> > fails with the above error. Any help/idea on what could be going on
> wrong.
> >
> > Below is the sample code I am using:
> >
> > SessionFactory sessionFactory = SessionFactoryImpl.newInstance();
> > Map<String, String> parameter = new HashMap<String, String>();
> >
> > // User credentials.
> > parameter.put(SessionParameter.USER, "user");
> > parameter.put(SessionParameter.PASSWORD, "xxxxxx");
> >
> > String wsdl = "file:cmissoapwsdl.wsdl";
> >
> > // Connection settings.
> > parameter.put(SessionParameter.BINDING_TYPE,
> > BindingType.WEBSERVICES.value());
> > parameter.put(SessionParameter.WEBSERVICES_ACL_SERVICE, wsdl);
> > parameter.put(SessionParameter.WEBSERVICES_DISCOVERY_SERVICE, wsdl);
> > parameter.put(SessionParameter.WEBSERVICES_MULTIFILING_SERVICE, wsdl);
> > parameter.put(SessionParameter.WEBSERVICES_NAVIGATION_SERVICE, wsdl);
> > parameter.put(SessionParameter.WEBSERVICES_OBJECT_SERVICE, wsdl);
> > parameter.put(SessionParameter.WEBSERVICES_POLICY_SERVICE, wsdl);
> > parameter.put(SessionParameter.WEBSERVICES_RELATIONSHIP_SERVICE, wsdl);
> > parameter.put(SessionParameter.WEBSERVICES_REPOSITORY_SERVICE, wsdl);
> > parameter.put(SessionParameter.WEBSERVICES_VERSIONING_SERVICE, wsdl);
> >
> > parameter.put(SessionParameter.AUTHENTICATION_PROVIDER_CLASS,
> > CmisBindingFactory.NTLM_AUTHENTICATION_PROVIDER); //Is this the cause of
> the
> > problem
> > parameter.put(SessionParameter.REPOSITORY_ID,
> > "0b6be23c-8331-42f4-b8be-2be07596912b");
> >
> > Session session = sessionFactory.createSession(parameter);
> >
> > if(session != null)
> > {
> >     System.out.println("SUCCESS: Got Session");
> > }
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message