chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Florian Müller <florian.muel...@alfresco.com>
Subject Re: Exception: 401 Unauthorized with Weblogic Server 11g R1
Date Mon, 24 Oct 2011 13:18:29 GMT
Hi Pankaj,

I guess ran into this SharePoint-Java-NTLM issue.

You probably need an Authenticator when you are using OpenCMIS within Weblogic (see [1]).
And I strongly recommend to reconfigure SharePoint to use basic authentication instead of
NTLM.


- Florian


[1] https://issues.apache.org/jira/browse/CMIS-423


On 24/10/2011 03:56, Pankaj Tiwari wrote:
> Hi,
> 
> Please ignore my earlier email. The issue is with my sharepoint
> configuration settings (not sure what it is). The same code on weblogic
> works fine with alfresco community repository.
> Need to figure out the exact cause.
> 
> Thanks,
> Pankaj
> 
> On Sun, Oct 23, 2011 at 11:33 PM, Pankaj Tiwari <panky.tiwari@gmail.com>wrote:
> 
>> Hi,
>>
>> I have a simple test program which runs successfully as standalone java
>> application. But, the same program when run under weblogic 11g r1 throws the
>> Exception:  401 Unauthorized.
>> I am using Sharepoint, webservices wsdl, Client is running on Weblogic 11g
>> r1. The map properties is same in both the cases.
>>
>> Map<String, String> props = getProperties(config);
>> List<Repository> repositories =
>> SessionFactoryImpl.newInstance().getRepositories(properties);
>>
>> Does weblogic server needs some configuration?
>>
>> Thanks,
>> Pankaj
>>
> 


Mime
View raw message