chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jens Hübel <jhue...@opentext.com>
Subject RE: Different result with same query but other OpenCMIS version
Date Wed, 20 Apr 2011 10:37:49 GMT
Does the Alfresco implementation use the opencmis query parser? Even that should not have been
changed with the exception of a few minor patches. Is there a chance to find out what native
queries are generated from the CMIS one?

Jens


-----Original Message-----
From: Geert Vanheusden [mailto:g.vanheusden@aca-it.be] 
Sent: Mittwoch, 20. April 2011 11:41
To: dev
Subject: Different result with same query but other OpenCMIS version

Dear,

I just upgraded to OpenCMIS 0.3.0 (coming from 0.2.0-incubating) and I noticed that the same
query I used before returns an incorrect result.

I have a custom document type (park:document) and a park:employeeDocument aspect.

When I execute the following query using OpenCMIS 0.2.0-incubating I have one document as
a result (correct). If I execute the same query using OpenCMIS 0.3.0 then there are no documents
returned.

cmisSession.query("
SELECT DOCUMENT.*, EMPLOYEEDOCUMENT.* 
FROM park:document AS DOCUMENT 
JOIN park:employeeDocument AS EMPLOYEEDOCUMENT 
ON DOCUMENT.cmis:objectId = EMPLOYEEDOCUMENT.cmis:objectId 
WHERE (EMPLOYEEDOCUMENT.employeeDoc:currentEmployeeName LIKE '%VANHEUSDEN%')
", false)

I am using the alfresco-opencmis-extension 0.2 and querying against an Alfreso enterprise
3.4.
If I execute the same query in the latest version of the OpenCMIS workbench I have also one
document as a result (correct).

Any ideas? Maybe a bug in OpenCMIS 0.3.0?

Kind regards,

Geert Vanheusden


_________________________________________________

 We published a new company movie featuring YOU!
         See http://www.aca-it.be/movie
_________________________________________________
Mime
View raw message