chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geert Vanheusden <g.vanheus...@aca-it.be>
Subject Re: getRenditions returns empty list
Date Thu, 03 Mar 2011 13:41:39 GMT
There appear to be a problem with the mail attachments.
Here the links:

http://dl.dropbox.com/u/623463/alf/document%20node.png
http://dl.dropbox.com/u/623463/alf/rendition%20node.png
http://dl.dropbox.com/u/623463/alf/workbench.png

Geert
----- Original Message -----
From: "Geert Vanheusden" <g.vanheusden@aca-it.be>
To: dev@chemistry.apache.org
Sent: Thursday, March 3, 2011 2:31:36 PM
Subject: getRenditions returns empty list

Hello,

I have a question about the getRenditions on QueryResult and CmisObject. 
I just created some renditions in Alfresco and they are visible in the OpenCMIS Workbench
under the Renditions tab.
When I try to iterate over the renditions in my own code I always receive an empty list. I
tested this on a QueryResult and a CmisObject.

Tested on:
* Alfresco Enterprise 3.4
* OpenCMIS 0.2.0-incubating
* alfresco-opencmis-extension-110208

* CMIS Workbench Version: 0.2.0-incubating-SNAPSHOT / Build: 20101006-1614

In the attachment you can find a screenshot of the source and rendition node and of the workbench.

Hope you can help me.

Kind regards,

Geert



_________________________________________________

 We published a new company movie featuring YOU!
         See http://www.aca-it.be/movie
_________________________________________________

Mime
View raw message