chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jens Hübel <jhue...@opentext.com>
Subject RE: Start-up issue with opencmis workbench
Date Fri, 07 Jan 2011 14:18:58 GMT
Hi Gab,

[3] works as expected. So fortunately no reason to rollback! :-)
This one also contains the missed scripts.

Perhaps I picked up the wrong zip from Hudson or it is only a build issue there. Thanks for
your link. 

Whatever it is we can figure out over time... So let's push the 0.2.0 release.


Jens


-----Original Message-----
From: Gabriele Columbro [mailto:columbro@gmail.com] 
Sent: Freitag, 7. Januar 2011 13:26
To: chemistry-dev@incubator.apache.org
Subject: Re: Start-up issue with opencmis workbench

Hi Jens,
I did not try the new trunk yet. Actually I'm in the process of
validating release artifacts (as you might have seen I've started the
release process yesterday).
I'm trying the release build [1] I did from the 0.2.0-incubating-RC1
tag [2] I was going to start a vote on, and:

- unzipping newly created assembly chemistry-opencmis-full.zip [3]
- running workbench.sh works fine for me

I refactored this assembly together with Florian prior to release to
have the assembly released as part of the commodity assemblies. Maybe
docs need update?

Might make sense to proceed with the release and fix these build
inconsistencies as separate issue for the 0.3.0-incubating release.

WDYT?

Let me know if I should complete the release or rollback the tags.
Gab


-
[1] https://repository.apache.org/content/repositories/orgapachechemistry-013/
[2] http://svn.apache.org/repos/asf/incubator/chemistry/opencmis/tags/chemistry-opencmis-0.2.0-incubating-RC1/
[3] https://repository.apache.org/content/repositories/orgapachechemistry-013/org/apache/chemistry/opencmis/chemistry-opencmis-workbench/0.2.0-incubating/chemistry-opencmis-workbench-0.2.0-incubating-full.zip

On Fri, Jan 7, 2011 at 11:22 AM, Jens Hübel <jhuebel@opentext.com> wrote:
>
> Hi Chemistries,
>
>
>
> has someone tried to run the CMIS workbench from the latest Hudson builds?
>
>
>
> I can't get it started:
>
> Exception in thread "AWT-EventQueue-0" java.lang.NoClassDefFoundError: org/apach
>
> e/chemistry/opencmis/client/api/ObjectId
>
>
>
> If I look at the class path in the manifest there are some strange file names. It seems
to be a mismatch with the file names that get packed in the .zip file:
>
>
>
> Class-Path: chemistry-opencmis-client-impl-0.3.0-incubating-SNAPSHOT.jar chemistry-opencmis-client-api-0.3.0-incubating20110106.152852-4.jar
chemistry-opencmis-commons-api-0.3.0-incubating-20110106.152852-4. jar commons-codec-1.4.jar
commons-logging-1.1.1.jar chemistry-opencmis-commons-impl-0.3.0-incubating-20110106.152852-4.jar
...
>
>
>
> Is this correct?
>
>
>
> If this is an issue we should get this fixed before the 0.2 release....
>
>
>
> And one more question: Have the startup scripts workbench.bat and workbench.sh been dropped
intentionally? My impression is that most people download it and start it from the downloaded
zip and do not want to make use of Java web start. So it would be nice to have this supported.
I found them useful.
>
>
>
> Jens
>
>
>



--
Eng. Gabriele Columbro
Open source and ECM Architect
Alfresco Ltd. - http://www.alfresco.com
-----------------------------------------
work: gabriele.columbro@alfresco.com
private: columbro@gmail.com
work:      (0031)   627 565 103
mobile:  (0039)    320 161 2846

yahoo: g.columbro
gtalk: columbro@gmail.com
AIM:   gabrielecolumbro

-----------------------------------------
"Keyboard not found.
 Press F1 to continue"
-----------------------------------------

Mime
View raw message