chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Florent Guillaume ...@nuxeo.com>
Subject various small cleanups
Date Thu, 09 Sep 2010 12:54:08 GMT
Hi,

A few things:

1.
Currently our iterators (CollectionIterator, CollectionPageIterator)
have a next() method that returns null at the end of the iteration.
This is wrong and contrary to the Iterator contract, they should
return NoSuchElementException in that case.
Anyone opposed to fixing this?

2.
Also I'd like to do small renamings like AbstractPageFetch ->
AbstractPageFetcher and PageFetchResult -> FetchedPage or maybe even
Page, and also rename getPage to getItems (or getList).

3.
ItemIterable.skipTo returns a new iterable. I'm used to skipTo methods
that just modify the iterable in place (for instance the JCR
RangeIterator.skip or JCR2 EventJournal.skipTo or Lucene Spans.skipTo
and TermDocs.skipTo), and in the use cases I've seen it's no use
creating a new object. Is it ok to change this?

4.
PageFetchResult has:
    public BigInteger getTotalItems()
    public Boolean getHasMoreItems()
whereas ItemIterable has:
    long getTotalNumItems();
    boolean getHasMoreItems();
I guess we have to keep Boolean and BigInteger to reflect the domain
model here, but I'll sync the naming.

Comments?

Florent

-- 
Florent Guillaume, Director of R&D, Nuxeo
Open Source, Java EE based, Enterprise Content Management (ECM)
http://www.nuxeo.com   http://www.nuxeo.org   +33 1 40 33 79 87

Mime
View raw message