chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Tesser <jasontes...@gmail.com>
Subject Re: Problem with repository implementation
Date Mon, 26 Oct 2009 16:35:35 GMT
Ok nevermind.

It was something dumb :-(

I had a filter in the way.  Appending a slash.  Got a new error but what was
happening made no sense.

Thanks,
Jason Tesser
dotCMS Lead Development Manager
1-305-858-1422


On Mon, Oct 26, 2009 at 12:15 PM, Jason Tesser <jasontesser@gmail.com>wrote:

> I am implementing my own repository. I am having an issue in the
> ServletRegexTargetResolver
>
> When I run the test which fires the MainServlet and uses Jettty to provide
> a default repository and I goto URL http://localhost:8080/cmis/repository
>
> the path in the ServletRegexTargetResolver is "repository" which matches
> the pattern.  this is good it works,
>
> I added my own CMISServlet to my web.xml which extends the Chemistry
> CMISServlet but calls super passing in my own Repository.  My reposity
> implements Repository, RepositoryCapabilities, and RepositoryInfo similar to
> the JCRRepository.
>
> I added the getter methods  for name, ID, info, and
> public ObjectId getRootFolderId() {
> //        return null;
>         return new SimpleObjectId(null);
> //        return new SimpleObjectId(DotRepository.escape("/"));
>     }
>
> All of which I tried to model after the JCRRepository.
>
> My problem is this
> When I use my servlet I get to the ServletRegexTargetResolver line 42-44
> the path has a "/" at the end.  When I run the test case MainServlet this is
> not true. I feel like I am missing something really dumb.
> Can someone please steer me in the right direction?
>
> Thanks,
> Jason Tesser
> dotCMS Lead Development Manager
> 1-305-858-1422
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message