celix-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gabriele Ricciardi (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CELIX-328) Service version support for RSA DFI
Date Tue, 05 Jan 2016 10:49:39 GMT

     [ https://issues.apache.org/jira/browse/CELIX-328?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gabriele Ricciardi updated CELIX-328:
-------------------------------------
    Attachment: dfi_version_support.patch

> Service version support for RSA DFI
> -----------------------------------
>
>                 Key: CELIX-328
>                 URL: https://issues.apache.org/jira/browse/CELIX-328
>             Project: Celix
>          Issue Type: Improvement
>            Reporter: Gabriele Ricciardi
>         Attachments: dfi_version_support.patch
>
>
> RSA DFI is missing support for version checking (i.e. if the service versions present
in client and server side's descriptor are compatible following the semantic versioning rules)
> Attached a patch that:
> - Implements the version support in RSA DFI
> - Fix a double free in importRegistration_destroy
> - Add a isCompatible function to version.c for checking if two versions are semantically
compatible (the unit tests are updated as well)
> - Fix the CMake files adding the DFI_LIBRARY_PATH
> - Fix and improve the calculator example
> - Add a deploy target for RSA DFI based on calculator example and discovery_etcd



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message