cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <>
Subject Re: Slight API curiosity
Date Fri, 16 Jun 2017 11:52:27 GMT
You mean Expression class has "andExp", not Property?

The answer is "legacy". This API predates Property, ObjectSelect, and other 4.0 additions.
It was done long time ago before we figured out our modern vocabulary.


> On Jun 16, 2017, at 1:56 PM, Hugi Thordarson <> wrote:
> Hi all,
> Is there any particular reason why Property has a method called "andExp()" instead of
"and()"? ObjectSelect and ExpressionFactory use the "and" method name, so it seems like using
the "and" method name would be more consistent (and more readable).
> Cheers,
> - hugi

View raw message