cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hugi Thordarson <h...@karlmenn.is>
Subject Re: Slight API curiosity
Date Fri, 16 Jun 2017 11:54:23 GMT
> You mean Expression class has "andExp", not Property?

Whoops—of course I did. Pardon me.


> The answer is "legacy". This API predates Property, ObjectSelect, and other 4.0 additions.
It was done long time ago before we figured out our modern vocabulary.

Might be a question of adding a new "and()" method and deprecating "andExp()"?

- hugi


> Andrus
> 
>> On Jun 16, 2017, at 1:56 PM, Hugi Thordarson <hugi@karlmenn.is> wrote:
>> 
>> Hi all,
>> Is there any particular reason why Property has a method called "andExp()" instead
of "and()"? ObjectSelect and ExpressionFactory use the "and" method name, so it seems like
using the "and" method name would be more consistent (and more readable).
>> 
>> Cheers,
>> - hugi

Mime
View raw message