cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Kienenberger <mkien...@gmail.com>
Subject Re: CayenneModeler not generating classes
Date Tue, 13 Oct 2015 14:18:21 GMT
I suspect the problem was using multiple lines rather than "and" and "or".

Since I have the various velocity versions checked out and worked with
the parser recently, I quickly scanned the code.    "and" and "or"
support was added for release 1.5, and exists in 1.6, 1.7, and 2.0.



On Tue, Oct 13, 2015 at 5:16 AM, Savva Kolbachev <s.kolbachev@gmail.com> wrote:
> Sorry, it was my mistake.
>
> I was confused by http://people.apache.org/~henning/velocity/html/ch06.html
> It really works with "and", "or" for me,  'org.apache.cayenne.exp.Property'
> is created and all the tests pass.
>
> Anyway I will apply Mike's fix.
>
> 2015-10-13 8:26 GMT+03:00 Dipesh Jain <dipesh@ivgroup.in>:
>
>> Hi Mike,
>>
>> I tried your solution and its worked. Thanks for the Help.
>>
>> On Sat, Oct 10, 2015 at 2:52 PM, Dipesh Jain <dipesh@ivgroup.in> wrote:
>>
>> > Hi Mike, As you said velocity version maybe has some problems so I had
>> > changed version from 1.6.4 but the output was same. I also tried with 1.7
>> > version but I got some errors and project was not build. I have created a
>> > fresh project for example. Here my xml files - *cayenne-Services.xml*
>> > <?xml version="1.0" encoding="utf-8"?> <domain project-version="7">
<map
>> > name="datamap"/> <node name="datanode"
>> > factory="org.apache.cayenne.configuration.server.DBCPDataSourceFactory"
>> > parameters="mastersdbcp2.properties"
>> >
>> schema-update-strategy="org.apache.cayenne.access.dbsync.SkipSchemaUpdateStrategy"
>> > > <map-ref name="datamap"/> </node> </domain> *datamap.map.xml*
<?xml
>> > version="1.0" encoding="utf-8"?> <data-map xmlns="
>> > http://cayenne.apache.org/schema/7/modelMap" xmlns:xsi="
>> > http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="
>> > http://cayenne.apache.org/schema/7/modelMap
>> > http://cayenne.apache.org/schema/7/modelMap.xsd" project-version="7">
>> > <property name="defaultPackage" value="com.iv.platform.dto"/> <db-entity
>> > name="Person"> <db-attribute name="DateofBirth" type="DATE"/>
>> <db-attribute
>> > name="Name" type="VARCHAR" length="100"/> <db-attribute name="PersonId"
>> > type="NUMERIC" isPrimaryKey="true" isMandatory="true" length="5"/>
>> > </db-entity> <obj-entity name="Person"
>> > className="com.iv.platform.dto.Person" dbEntityName="Person">
>> > <obj-attribute name="dateofBirth" type="java.util.Date"
>> > db-attribute-path="DateofBirth"/> <obj-attribute name="name"
>> > type="java.lang.String" db-attribute-path="Name"/> </obj-entity>
>> > </data-map> After creating project, DB and Obj entity. As per
>> Documentation
>> > I have clicked on tools menu to generate classes. On popup dialog box I
>> > have changed nothing just clicked on Generate button, and I got that
>> error.
>> > My Person file was generated in com.iv.platform.auto package but it was
>> > empty. Hii Andrus, I apologize that I can not provide screenshots, and as
>> > you said >> Looks like Dipesh is using the Modeler for class generation.
>> > Does that mean we can generate classes without Modeler ? and as per the
>> > documentation and comment in generated class in Cayenne 3.1 /** * Class
>> > _PersonTemp was generated by Cayenne. * It is probably a good idea to
>> avoid
>> > changing this class manually, * since it may be overwritten next time
>> code
>> > is regenerated. * If you need to make any customizations, please use
>> > subclass. */ I understood that I have to create classes form Modeler. Is
>> > there any other way or I can generate POJO classes from my end and use it
>> > in Cayenne. -- Thanks and Regards Deepesh Jain
>> >
>>
>>
>>
>> --
>> Thanks and Regards
>> Deepesh Jain
>>

Mime
View raw message