cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Baldwin <jfbald...@earthlink.net>
Subject Re: Version API
Date Mon, 27 Jul 2015 10:55:38 GMT
I am looking for a simple replacement for version 3.0 API 

>> 	org.apache.cayenne.project.Project.CURRENT_PROJECT_VERSION


since it appears to be missing in 4.0.

I could find no reference to any of the classes you mention in your 4.0 API. Do you have a
url reference?



> On Jul 27, 2015, at 5:06 AM, Andrus Adamchik <andrus@objectstyle.org> wrote:
> 
> Not sure in what context you are using that, but "cayenne-project" DI module now has
a service org.apache.cayenne.project.ProjectUpgrader that gives you access to UpgradeHandler
that gives you access to UpgradeMetaData. UpgradeMetaData has the version supported by a given
runtime.
> 
> Andrus
> 
>> On Jul 26, 2015, at 8:41 PM, Joe Baldwin <jfbaldwin@earthlink.net> wrote:
>> 
>> Migration 3.0 => 4.0
>> 
>> 	org.apache.cayenne.project.Project.CURRENT_PROJECT_VERSION
>> 
>> appears to be no longer supported in 4.0.
>> 
>> Is there a substitute (as easy to access)?
>> 
>> 
>> 
> 


Mime
View raw message