cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Huss <johnth...@gmail.com>
Subject Re: Version Compatibility
Date Fri, 15 Aug 2014 20:28:34 GMT
The version of MySQL depends only on your JDBC driver, it doesn't matter to
cayenne (well, it shouldn't).

Tomcat is completely unrelated too.  But "as much as possible" is a bad
recommendation.

So the Java version is all that matters, and like you said 3.1 requires
Java 1.5+




On Fri, Aug 15, 2014 at 3:09 PM, Joe Baldwin <jfbaldwin@earthlink.net>
wrote:

> I have been using 3.0 for a while now (since it is listed as “stable”).
> But then I read one of the posts in which it was recommended to use 3.1
> (rc).  So since I am getting ready to change servers, I though I would take
> the opportunity to upgrade versions as well.
>
> However, I could not find a compatibility matrix.  I did find the
> requirement of Java 1.5 or above.
>
> I am currently using:
>
>         Cayenne: 3.0
>         Java: 1.7
>         MySQL 5.1
>
> I plan to change to
>
>         Cayenne: 3.1
>         Java: 1.7
>         MySQL 5.6
>
> First: is this reasonable?  Second, is there a version matrix at
> cayenne.apache.org I can peruse?  Third, what is recommended for
> stability and performance?  I presume I need a minimum Tomcat memory
> allocation (the last recommendation I recall was: “as much as possible” :) )
>
> Thanks,
> Joe
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message