cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <and...@objectstyle.org>
Subject Re: CayenneModeler 3.2M1 on Mac OS X Mavericks
Date Wed, 06 Nov 2013 15:14:13 GMT
Wonder if we can contribute a patch to OpenJDK :) It is open source these days, right?

A.

On Nov 6, 2013, at 5:55 PM, Michael Gentry <mgentry@masslight.net> wrote:

> Interesting information.  It looks like you'd have to update Info.plist
> every time you applied a Java update, though?  (Since it is located under
> jdk1.7.0_45.jdk.)
> 
> mrg
> 
> 
> 
> On Wed, Nov 6, 2013 at 6:55 AM, D Tim Cummings <tim@triptera.com.au> wrote:
> 
>> I can confirm that installing java 6 from Apple solved the problem. This
>> probably won't be a common use case now but in the future I am sure Apple
>> will stop installing java 6.
>> 
>> To prevent Java 6 from wanting to install, I had edited
>> /Library/Java/JavaVirtualMachines/jdk1.7.0_45.jdk/Contents/Info.plist
>> 
>> and replaced
>> 
>> <key>JVMCapabilities</key>
>> <array>
>>  <string>CommandLine</string>
>> </array>
>> 
>> with the following:
>> 
>> <key>JVMCapabilities</key>
>> <array>
>>  <string>JNI</string>
>>  <string>BundledApp</string>
>>  <string>WebStart</string>
>>  <string>Applets</string>
>>  <string>CommandLine</string>
>> </array>
>> 
>> Java 7 has been working fine with other java apps such as eclipse.
>> 
>> Tim
>> 
>> 
>> On 6 Nov 2013, at 8:00 pm, Andrus Adamchik <andrus@objectstyle.org> wrote:
>> 
>>> Seems to work for me.
>>> 
>>>> Additional information, I don't have the Apple java 1.6 installed. Only
>> Oracle jdk1.7.0_45
>>> 
>>> I actually have Java 6 (side by side with 7), and this is what Modeler
>> is using. Java 6 was removed during mavericks upgrade, but when I clicked
>> on Eclipse app for the first time, it prompted me to install it.
>>> 
>>> Anyways, looks like we need to test a Java7-only case.
>>> 
>>> Andrus
>>> 
>>> 
>>> 
>>> On Nov 6, 2013, at 12:17 PM, D Tim Cummings <tim@triptera.com.au> wrote:
>>>> I have just upgraded to Mac OS X Mavericks and the Mac specific
>> CayenneModeler 3.2M1 is no longer working. It just won't open. When I tried
>> installing again, Mavericks says CayenneModeler is damaged and gives me the
>> option to delete it. I have started using the platform independent version
>> of CayenneModeler 3.2M1 on Mavericks now and it works fine.
>>>> 
>>>> Additional information, I don't have the Apple java 1.6 installed. Only
>> Oracle jdk1.7.0_45
>>>> 
>>>> Is anyone else having this problem?
>>>> 
>>>> Tim
>>> 
>> 
>> 


Mime
View raw message