cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Willerding <awillerd...@itsurcom.com>
Subject Re: Can't instantiate class but it exists (fixed Netbeans issue)
Date Thu, 01 Aug 2013 14:34:21 GMT

>> What is really strange now is that I have been using my linux workstation to do my
work and report this issue I'm experiencing and I'm currently out of the office so I've switched
to my Windows laptop and tried to run the same project and IT WORKS!  I do not get the same
error.  Until now I have not tried to run it from my laptop before.  Maybe my Netbeans setup
on my linux workstation is hosed somehow.  I will reinstall it from scratch and see if that
helps out.  I won't be able to do this until tomorrow.   The only differences on the Windows
laptop are jdk1.7.0.21 and Tomcat 7.0.34.  Netbeans is the same version and my application
code is exactly the same.
>>
>>
Well it works now.  On my Linux W/S I upgraded the Oracle JDK to 
1.7.0.25 and Tomcat to 7.0.42 - both the latest versions - modified 
Netbeans (7.3.1)  to make use of both for my project, did a "clean and 
rebuild" on the project and the errors have disappeared!!  No more 
instantiate issues.  If I wouldn't have had a need to switch computers 
yesterday I would never have suspected something in the Netbeans 
environment as having the issue because of the red-herring error 
messages pointing to Cayenne.  I'm not sure I'll ever find the root 
cause but I'm happy I can continue along on my project now with my 
favourite ORM framework.

Thank you so much to everyone for your suggestions and letting me sound 
out on this list without judgment!!

Mime
View raw message