cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Scheibe <dscheib...@googlemail.com>
Subject Re: Problem with type: long[]
Date Fri, 22 Mar 2013 15:53:31 GMT
Hi,

glad you found it, i was about to nail it down too but you were faster... :)

Cheers,
Daniel

Am 22.03.2013 16:02, schrieb Kris Erik Schwerdt:
> Hi,
>
> thanks again. I think I found the problem and created a patch for the
> source code and submit it in the bug tracker.
>
> The problem is in org.apache.cayenne.util.Util where is missing some
> lines of code for the case of a long[].
>
> Greetings,
> Kris Erik.
>
> Am 22.03.2013 14:35, schrieb Kris Erik Schwerdt:
>> Hi Daniel,
>>
>> thanks for your fast reply.
>> I'm using the mysql, you can find an copy of my test project in
>> attachment.
>>
>> Greetings,
>> Kris Erik.
>>
>> Am Fr 22 Mär 2013 14:02:33 CET schrieb Daniel Scheibe:
>>> Hi,
>>>
>>> which Database Adapter are you using? A little excerpt of your code
>>> would help too.
>>>
>>> Cheers,
>>> Daniel
>>>
>>> Am 22.03.2013 13:53, schrieb Kris Erik Schwerdt:
>>>> Hi,
>>>>
>>>> I'm now using cayenne for a while. Currently I run version 3.0.2 but
>>>> 3.1M3 seems to have the same problem.
>>>> I want to save an array as a blob in the database. When I'm using the
>>>> type int[] or char[] or double[] everything is ok.
>>>> But I need an array of the type long[]. Cayenne writes this array as the
>>>> object reference into the database, but it does not write the content of
>>>> the array into the field.
>>>>
>>>> Greetings
>>>> Kris Erik Schwerdt.
>>>>
>>>


Mime
View raw message