cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <and...@objectstyle.org>
Subject Re: Cross Database Queries
Date Tue, 05 Jun 2012 11:42:08 GMT
Hi Gary,

are there any matching table names between "jay" and "jayExtranet" DataMaps?

Andrus

On Jun 5, 2012, at 2:28 PM, Gary Jarrel wrote:

> Hi Bryan,
> 
> Thank you for the response.
> 
> When pasting I omitted the XML declaration at the top: <?xml
> version="1.0" encoding="utf-8"?> perhaps that is why it did not load?
> 
> I am using container defined JNDI data sources, hence there is no
> driver declaration. When the application starts it actually connected
> to both data sources perfectly fine and I get the following log
> entries:
> 
> Connecting. JNDI path: java:comp/env/jdbc/jayExtranet
> +++ Connecting: SUCCESS.
> 
> Connecting. JNDI path: java:comp/env/jdbc/jay
> +++ Connecting: SUCCESS.
> 
> It when I run the query, it appears to forget about the jayExtranet
> datasource thinking that 'dbo.client_contracts' comes from jay data
> source.
> 
> Thank you
> 
> Gary
> On Tue, Jun 5, 2012 at 9:14 PM, Bryan Lewis <jbryanlewis@gmail.com> wrote:
>> I got cross-database queries working just recently, with a boost from
>> Michael Gentry.  I'd guess the culprit is that your nodes are missing the
>> datasource.  For example:
>> 
>> <node name="DataNode"
>>         datasource="DataNode.driver.xml"   // tell the node how to connect
>> to the database
>> 
>> In fact I'm kinda surprised it works at all.  The modeler won't load the
>> file.  Maybe your note didn't include an exact copy.
>> 
> <snip>
> 


Mime
View raw message