cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Gentry <mgen...@masslight.net>
Subject Re: Cayenne with the last Velocity release
Date Sat, 09 Jun 2012 12:34:16 GMT
"The project I have is not Maven-based..."

Sorry, I missed that.  What are you using to build?  If you are
manually managing JARs, you could always unpack the Cayenne JAR, rip
the old Velocity JAR out of it, and re-package it.

mrg


On Sat, Jun 9, 2012 at 8:19 AM, Michael Gentry <mgentry@masslight.net> wrote:
> Hi Paulo,
>
> If you are using Maven to build your project, exclude Velocity from
> the Cayenne dependency:
>
> <dependency>
>  <groupId>org.apache.cayenne</groupId>
>  <artifactId>cayenne-server</artifactId>
>  <version>3.0.2</version>
>  <type>jar</type>
>  <scope>compile</scope>
>  <exclusions>
>    <exclusion>
>      <groupId>velocity</groupId>
>      <artifactId>velocity</artifactId>
>    </exclusion>
>  </exclusions>
> </dependency>
>
> Then include your 1.7 dependency and Maven should package the correct
> Velocity jar for you.  Cayenne's usage of Velocity is trivial and it
> shouldn't be impacted by the version switch.
>
> If you are using a different tool to build, I'm sure there is an
> exclusion option for it as well.
>
> mrg
>
>
> On Fri, Jun 8, 2012 at 9:43 PM, Paulo Roberto Massa Cereda
> <cereda.paulo@gmail.com> wrote:
>> Dear friends,
>>
>> First of all, kudos to all developers for this great project. :) I have to
>> say I'm really impressed and satisfied with Cayenne. It really makes things
>> easier to model and implement.
>>
>> First of all, apologies if this subject is recurring in the mailing list. I
>> tried to follow some past messages hoping to find a workaround, but I had no
>> luck so far.
>>
>> One specific application of mine makes heavy use of Velocity for generating
>> reports and other kinds of documents. Most of my templates are really
>> complex, they make use of several features included in the most recent
>> Velocity release (1.7). Long story short: these templates are not properly
>> generated from Velocity shipped with Cayenne. :)
>>
>> I would like to hear from you experienced Cayenne users if anyone has a
>> successful story of Cayenne working with Velocity 1.7. The project I have is
>> not Maven-based, but I don't see any restrictions in a possible migration if
>> a possible solution requires it.
>>
>> Thanks a lot for your time, and again thanks for making Cayenne a jewel in
>> software development.
>>
>> Best wishes,
>>
>> Paulo

Mime
View raw message