cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kanwar Manish <kanwarman...@gmail.com>
Subject Re: Unable to get the relationships defined in Modeller to the PostgreSQL DB
Date Mon, 23 Apr 2012 16:08:52 GMT
Yes, I had all the check boxes checked in the SQL Options tab. And I had
all the tables selected in the Tables tab.

Any other option that I might have missed?

Thanks
Manish


On Mon, Apr 23, 2012 at 8:07 PM, Michael Gentry <mgentry@masslight.net>wrote:

> When you generated your schema in Cayenne Modeler, did you have the
> "Create FK Support" checkbox selected?
>
>
> On Mon, Apr 23, 2012 at 10:22 AM, Kanwar Manish <kanwarmanish@gmail.com>
> wrote:
> > Sorry for the typo. Yes - I meant constraints.
> >
> > Thanks
> > KM
> >
> > Sent from my iPhone
> >
> >
> > On 23-Apr-2012, at 7:27 PM, Michael Gentry <mgentry@masslight.net>
> wrote:
> >
> >> Hi there,
> >>
> >> I'm not sure what you meant by "the relationships are not getting
> >> created in the DB."  Are you talking about constraints being created?
> >>
> >> Thanks,
> >>
> >> mrg
> >>
> >>
> >> On Mon, Apr 23, 2012 at 9:03 AM, Kanwar Manish <kanwarmanish@gmail.com>
> >> wrote:
> >>>
> >>> Hi All
> >>>
> >>> I am using Cayenne Modeller version 3.0.2.   I am using PostgreSQL 9.1
> >>> installed locally. Environment is windows XP.
> >>>
> >>> I have defined my data map and added all the tables required in the
> DB. I
> >>> have also defined some relationships.
> >>>
> >>> I am able to generate the database schema and the tables are being
> >>> successfully created in the PostgreSQL. However the relationships are
> not
> >>> getting created in the DB. I am not getting any errors.
> >>>
> >>> Any ideas?
> >>>
> >>> Thanks in Advance
> >>> KM
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message