cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Fischer <farkmisc...@gmail.com>
Subject Re: Reengineer Database Schema not generating anything
Date Thu, 11 Nov 2010 16:41:31 GMT
That did it!!!  I must admit that maybe because I am from a visual studio or
windows background I have never had to "Select Schema" like I do with
Cayenne and so I had to idea what to pick 3-4 weeks ago when I first tried
Cayenne.  When you connect from visual studio you just give the url and
username and password, there is no schema to select from.  Also, when I
wrote the small jdbc program to check my connection it did not ask me for a
schema.  What does the schema do?

When I first tried this 3-4 weeks ago  I started at the top with
"db_accessadmin" and worked my way down through the 13 options to "db_owner"
and gave up.  There were still 5 choices left but I figured that if
"db_owner" did not have the proper rights then none of the others would.  I
went into SQL Server and made sure that "db_owner" was assigned full rights
before I gave up.  Turns out if I pick "sys" I get a Map with all the tables
including the system tables and if I pick "dbo" I get all the non system
tables.  Any idea why "dbo" works but "db_owner" does not?  My knowledge of
databases is not extensive so I must admit I do not know much about how the
schemas work in SQL Server.

Sorry if this was a dumb error and wasting everyones time.  Thanks for
sticking it out with me!!!

Mark

On Wed, Nov 10, 2010 at 2:22 PM, bogdan_voloshincu <
bogdan_voloshincu@yahoo.com> wrote:

>
> take a look :
>
> http://cayenne.195.n3.nabble.com/Help-cdbimport-Oracle-td1876015.html#a1876015
> --
> View this message in context:
> http://cayenne.195.n3.nabble.com/Reengineer-Database-Schema-not-generating-anything-tp1831261p1878441.html
> Sent from the Cayenne - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message