cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aristedes Maniatis <...@maniatis.org>
Subject Re: problems after upgrading jetty and hessian to the latest version
Date Tue, 23 Nov 2010 08:57:12 GMT
I can confirm that just swapping in the latest Hessian 4 binary breaks the Cayenne tests, although
I did not spend any time trying to identify exactly what the issue was.

Also, the version of Hessian we are using (3.1.6) looks to be missing from Maven Central.
I would have sworn it was there before, but it can be found only at the caucho repository
as far as I can tell. Should we push it to maven central ourselves or add the caucho repo
to our pom?

Ari



On 23/11/10 7:46 PM, Andrus Adamchik wrote:
> Haven't tried the latest Hessian, but historically Hessian arbitrarily changed the serialization
protocol between versions, so switching to a newer version required some tweaking on our end.
>
> Jetty 7 on the other hand just works... The only thing that caused me trouble with 6->7
upgrade about a year ago, was a change in cookie encoding algorithm.
>
> Andrus
>
>
> On Nov 17, 2010, at 12:33 AM, Marcin Skladaniec wrote:
>
>> Hello
>>
>> I was wondering if someone has tried cayenne with jetty 7 and hessian 4.
>>
>> After some trial and error I finally got to the stage where servlet is replying,
but cayenne fails to establish ClientChannel. this is the log
>>
>> org.apache.cayenne.CayenneRuntimeException: [v.3.0.1 Aug 04 2010 18:38:23] Error
establishing remote session. URL - http://localhost:8181/angel-server-cayenne; CAUSE - expected
integer at 0x53 java.lang.String (org.apache.cayenne.remote.RemoteSession)
>>     [java]   [O] S [\x00'org.apache.cayenne.remote.RemoteSession\x94\x04name\x09sessionId\x12eventBridgeFactory\x15eventBridgeParameterso\x90N\x1913mrh1ds35gq3cu0vcyroaazzNNz]
>> at org.apache.cayenne.remote.hessian.HessianConnection.connect(HessianConnection.java:229)
>>     [java]     at org.apache.cayenne.remote.hessian.HessianConnection.getServerEventBridge(HessianConnection.java:114)
>>     [java]     at org.apache.cayenne.remote.ClientChannel.setupRemoteChannelListener(ClientChannel.java:299)
>>     [java]     at org.apache.cayenne.remote.ClientChannel.<init>(ClientChannel.java:95)
>>     [java]     at org.apache.cayenne.remote.ClientChannel.<init>(ClientChannel.java:77)
>>     [java]     at org.apache.cayenne.remote.ClientChannel.<init>(ClientChannel.java:72)
>>     [java]     at ish.oncourse.ContextManager.getDataChannel(ContextManager.java:84)
>>     [java]     at ish.oncourse.ContextManager.getChannel(ContextManager.java:70)
>>     [java]     at ish.oncourse.ContextManager.getNewDedicatedContext(ContextManager.java:111)
>>     [java]     at ish.oncourse.controller.ViewController.getContext(ViewController.java:1091)
>>
>> seems like something has changed on the deserialisation level(?) in hessian, but
I cannot pinpoint what.
>>
>> Has someone hit or maybe solved this problem?
>> Thanks
>> Marcin
>>
>

-- 
-------------------------->
Aristedes Maniatis
GPG fingerprint CBFB 84B4 738D 4E87 5E5C  5EFA EF6A 7D2E 3E49 102A

Mime
View raw message