cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bogdan_voloshincu <bogdan_voloshi...@yahoo.com>
Subject Re: pls helppppp !!! cayenne.xml
Date Sun, 21 Nov 2010 12:18:37 GMT

Thank you Andrus but for me  it doesn't   work   and i think is because when
the application run  Cayenne loads the informations from resources at start
up. i have see that i can setup domains this way : 

---------------------------------------------------------------------

DataSource dataSource = new PoolManager("org.postgresql.Driver",
"jdbc:postgresql://localhost:5432/postgres", 1,4,"postgres","root");
                                         DataNode dn = new DataNode();
				         dn.setDataSource(dataSource);
                                        
					 DataMap dm = new DataMap();
					 dm.setDefaultSchema("public");
					 dm.setDefaultPackage("psql");
					 
                                         DataDomain dd = new
DataDomain("Ab");
					 dd.addMap(dm);
                                         dd.addNode(dn);
                                           

                                        conf.addDomain(dd);
					
					
-----------------------------------------------------------


but when i pass the domain name to :

ObjectContext ov = DataContext.createDataContext(Domain Name);   it doesn't
show anything not even a error message .
-- 
View this message in context: http://cayenne.195.n3.nabble.com/pls-helppppp-cayenne-xml-tp1939034p1939853.html
Sent from the Cayenne - User mailing list archive at Nabble.com.

Mime
View raw message