cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <and...@objectstyle.org>
Subject Re: maven-cayenne-plugin cgen issue
Date Mon, 11 Oct 2010 11:20:03 GMT
Seems like a bug. I opened a Jira: https://issues.apache.org/jira/browse/CAY-1490

Andrus

On Oct 9, 2010, at 12:15 AM, Alexander Yaremenko wrote:

> Andrus,
> that did not help either. Here is extract from my pom:
> 
> <plugins>
> 	<plugin>
> 				<groupId>org.apache.cayenne.plugins</groupId>
>        <artifactId>maven-cayenne-plugin</artifactId>
>      	    	<version>3.0.1</version>     	    	
> 			<executions>
> 				<execution>
> 					<id>cgen</id>
>      		    		<configuration>
>      						<map>${project.build.sourceDirectory}/../resources/CdwDbMap.map.xml</map>
>         <destDir>${project.build.sourceDirectory}</destDir>
>                        	<superPkg>x.y.persistance.ormimpl.auto</superPkg>
> 							<mode>all</mode>
>      		    		</configuration>
>      		    		<goals>
>      						<goal>cgen</goal>
>      		    		</goals>
> 						
> 					</execution>
> 					<execution>
> 						<id>cgen-2</id>
>      		    		<configuration>
>      						<map>${project.build.sourceDirectory}/../resources/NpmDbMap.map.xml</map>
>                        	<destDir>${project.build.sourceDirectory}</destDir>
>                        	<superPkg>x.y.persistance.ormimpl.auto</superPkg>
> 							<mode>all</mode>
>      		    		</configuration>
>      		    		<goals>
>      						<goal>cgen</goal>
>      		    		</goals>
> 					</execution>
> 
> 				</executions>
> 			</plugin>
> 		</plugins>
> 
> --
> Alex
> 
>> Hi Alex,
> 
>> Try setting "mode" property of the plugin to "all" (valid values are >"entity"
- the default,
>> "datamap", "all").
> 
>> I noticed this is undocumented. Let me update the site docs in the >meantime.
> 
>> Andrus
> 
> On Oct 7, 2010, at 1:10 AM, Alexander Yaremenko wrote:
> 
>> Hi,
>> I could not generate classes related to map itself (_*Map.java). They are generated
by
> modeler but not with this maven plugin. All other classes defined in the map are generated
> just fine.
>> I was trying v. 3.0 and 3.0.1 of the plugin with the same result.
>> 
>> Any help is appreciated.
>> --
>> Alex
>> 
> 
> 


Mime
View raw message