cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Zeigler <robert.zeig...@roxanemy.com>
Subject Re: Cayenne vs Hibernate Comparison
Date Wed, 29 Sep 2010 16:25:13 GMT
Ok, so, t5c doesn't depend on resin-hessian directly; cayenne-rop does.  Since I've done cayenne
dev work, I already had the dependency.  Are you using tapestry-cayenne-server, or tapestry-cayenne-client?
server shouldn't need the dependency at all; if it's complaining about it, let me know and
I'll dig a little more.

Robert

On Sep 29, 2010, at 9/298:59 AM , Borut Bolčina wrote:

> This is what I got, but mind I am behind company nexus - I'll try at home
> with clean local repo.
> 
> 
> Missing:
> ----------
> 1) com.caucho:resin-hessian:jar:3.1.6
> 
>  Try downloading the file manually from the project website.
> 
>  Then, install it using the command:
>      mvn install:install-file -DgroupId=com.caucho
> -DartifactId=resin-hessian -Dversion=3.1.6 -Dpackaging=jar
> -Dfile=/path/to/fil
> e
> 
>  Alternatively, if you host your own repository you can deploy the file
> there:
>      mvn deploy:deploy-file -DgroupId=com.caucho -DartifactId=resin-hessian
> -Dversion=3.1.6 -Dpackaging=jar -Dfile=/path/to/file
> -Durl=[url] -DrepositoryId=[id]
> 
>  Path to dependency:
>        1)
> com.googlecode.tapestry5-cayenne:tapestry5-cayenne-client:jar:0.3-SNAPSHOT
>        2) org.apache.cayenne:cayenne-client:jar:3.0
>        3) com.caucho:resin-hessian:jar:3.1.6
> 
> ----------
> 1 required artifact is missing.
> 
> for artifact:
>  com.googlecode.tapestry5-cayenne:tapestry5-cayenne-client:jar:0.3-SNAPSHOT
> 
> from the specified remote repositories:
>  apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository),
>  central (https://nexus.interseek.com/content/groups/releases),
>  tapestry-snapshots (http://tapestry.formos.com/maven-snapshot-repository/
> ),
>  tapestry-pending-releases (
> http://people.apache.org/~hlship/tapestry-ibiblio-rsynch-repository/),
>  cayenne.deps (http://objectstyle.org/maven2)
> 
> 
> 
> Best,
> Borut
> 
> 
> 2010/9/29 Robert Zeigler <robert.zeigler@roxanemy.com>
> 
>> Hm.  Strange.. I work on it frequently, and compile it fine w/out that
>> dependency?
>> 
>> I'll check into this.
>> 
>> Robert
>> 
>> On Sep 29, 2010, at 9/298:39 AM , Borut Bolčina wrote:
>> 
>>> Hi Robert (and others),
>>> 
>>> I am starting one fresh project and wanted to test-drive t5cayenne. For
>>> trunk sources to compile you have to add
>>> 
>>>       <repository>
>>>         <id>caucho</id>
>>>         <url>http://caucho.com/m2</url>
>>>       </repository>
>>> 
>>> in the parent POM. Now lets take this baby for a spin :-)
>>> 
>>> -Borut
>>> 
>>> 2010/9/6 Robert Zeigler <robert.zeigler@roxanemy.com>
>>> 
>>>> 
>>>> Check out the trunk source? It's compatible with T5.2.  At least, I have
>>>> projects that are running with T5.2 and the latest t5cayenne source. :)
>>>> Sorry, I've been crazy busy lately and haven't had time to put together
>> a
>>>> real release.  But the code has made some nice progress in the last 6
>> weeks
>>>> or so, including T5.2 compatibility and improved ValueEncoder support
>> (trunk
>>>> adds support for multi-key PK's. Take that, tapestry-hibernate! ;).  I'm
>>>> also planning on either updating the EntityField, or creating an
>> alternative
>>>> component (and deprecating EntityField) that works better.  I have a
>> working
>>>> prototype of said new component in a personal project I'm working on,
>> but it
>>>> still has a couple of quirks that I need to fix before moving it
>> directly
>>>> into T5cayenne.
>>>> 
>>>> Robert
>>>> 
>>>> 
>> 
>> 


Mime
View raw message