cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <and...@objectstyle.org>
Subject Re: Building dataview jar for use with Cayenne 3.0 (or...is ANYONE using dataviews in 3.0?)
Date Thu, 20 May 2010 14:23:49 GMT
Just committed changes to the POM files to make sure DV is using  
Cayenne 3.0-final, and a few more. Here is a commit comment:

* Jira has moved
* making POM independent from Cayenne POM
* setting Cayenne version at 3.0
* switching Java compiler settings to 1.5

Hope this will get you going.

Cheers,
Andrus


On May 20, 2010, at 10:40 AM, Andrus Adamchik wrote:

> Hi Mark,
>
> let me fix up the POM removing snapshot references and try building  
> it myself. I will let you know when this is done.
>
> Andrus
>
>
> On May 20, 2010, at 12:13 AM, Mark Fraser wrote:
>> I am trying to migrate a Cayenne 2.0.4 project that is a swing- 
>> based desktop
>> application that heavily uses data views.  The reason I have not  
>> migrated
>> previously is that previous attempts have failed due to a myriad of  
>> problems
>> created in large part due to the removal of dataviews from the main
>> project.  I am trying again (one last time) and am having a problem  
>> right
>> from the start that I need help with.
>>
>> I figured the first thing I need to do is make sure I can build the  
>> dataview
>> jar as explained here:
>>
>> https://svn.apache.org/repos/asf/cayenne/dataviews/trunk/README.txt
>>
>> When I check out the code and run 'mvn clean install' I immediately  
>> get the
>> following error:
>>
>> ---------------
>> [INFO] Scanning for projects...
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] FATAL ERROR
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Error building POM (may not be this project's POM).
>>
>> Project ID: org.apache.cayenne.dataview:dataview-parent:pom:3.0- 
>> SNAPSHOT
>>
>> Reason: Cannot find parent: org.apache.cayenne:cayenne-parent for  
>> project:
>> org.apache.cayenne.dataview:dataview-parent:pom:3.0-SNAPSHOT for  
>> project
>> org.apache.cayenne.dataview:dataview-parent:pom:3.0-SNAPSHOT
>> ---------------
>>
>> I then tried compiling the main cayenne trunk and this successfully  
>> compiled
>> and added to my maven repository...but the same error occurred when  
>> I went
>> back and tried compiling the dataview project again.
>>
>> I am not thoroughly familiar with Maven so I'm not sure if the  
>> problem is
>> with my setup or with the pom.xml or what.
>>
>> Any help would be appreciated.
>>
>> Thanks,
>>
>> Mark
>
>


Mime
View raw message