cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Gentry" <blackn...@gmail.com>
Subject Re: Cayenne, XML objects and JDBC 4
Date Mon, 15 Sep 2008 15:18:47 GMT
Another comment regarding JDK 1.6 ...

Not too long ago, we made the decision to require JDK 1.5 for Cayenne
3.  This decision was not done lightly and there was unanimous consent
from people on the user (not just developer) list to do so.  Since
Cayenne is really designed to be a server-side framework, we have to
be cognizant of  server-side deployments of J2EE and stand-alone
applications, from both a hardware and a software perspective.  Even
just a year ago, there were still many servers which only had Java 1.4
installed on them or were running a J2EE container that required Java
1.4.  (I personally had deployed an application using Cayenne into
WebLogic on Solaris using JDK 1.4.)  I think Java 1.6 is at least
another year off for us.

/dev/mrg

Mime
View raw message