cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Kienenberger" <mkien...@gmail.com>
Subject Re: Cayenne version 3.0 compatible java 1.4
Date Fri, 13 Jun 2008 18:51:36 GMT
Unless there's something 3.0 M1 or M2 specific that you need, you will
be better off with 2.0 (1.2).  2.0 is maintained and bugs are fixed.
That will not be true for 3.0M2.

If you're going to use 3.0M2, you should probably plan on building it
from svn as you'll have to maintain patches yourself.

Another possibility you may want to investigate is retroweaver.   In
theory you can use it to recompile 3.0 into Java 1.4 compatible byte
code.   Report back on how well this works if you go this route.  I
know it's successfully used by other Java 5 projects to maintain 1.4
binary compatiblity (like Myfaces Tobago).

http://retroweaver.sourceforge.net/

On 6/13/08, hans <hans@welinux.cl> wrote:
> Please,
>
>  I was forced to downgrade to java 1.4.
>
>  I need Cayenne version 3.0 compatible with java 1.4, until i know the 1.5
>  switch was after 3.0M2,  where can i get a it  without resorting to svn ?
>
>  Atte
>
> Hans
>
>
>
>
>

Mime
View raw message