cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Lamb (dev)" <al...@mac.com>
Subject Re: Problem with 3.0M3 (Null pointer): More info
Date Tue, 05 Feb 2008 11:21:02 GMT
More info:

What happened is that we have class hierarchies in our models. With  
M2, it works. With M3, it doesn't. What is also curious is that the  
interface in the Modeler of M3 does not allow anymore to have a DB  
Entity inherit from another DB Entity ?? I guess that is the problem  
since reverting to an M2 version of our models and running the exact  
same code with M2 works.

Alex

Le 5 févr. 08 à 12:05, Alexander Lamb (dev) a écrit :

> Ok, I will try.
>
> Maybe the model but I maybe did something stupid: I opened the  
> models with the M3 modeler then saved them. Still the crash. Then  
> reverted to M2 (without changing the models). Again a crash....  
> which seems to tell us it is not M3.
>
> But: are the model formats compatible between M2 and M3 ? In other  
> words, can  I continue to work with M3 modeler whatever version M2  
> or M3 of Cayenne I am using?
>
> Thanks,
>
> Alex
>
> Le 5 févr. 08 à 10:13, Andrus Adamchik a écrit :
>
>>
>> On Feb 5, 2008, at 11:02 AM, Alexander Lamb (dev) wrote:
>>
>>> Caused by: java.lang.NullPointerException
>>> 	at  
>>> org 
>>> .apache 
>>> .cayenne 
>>> .map.AshwoodEntitySorter.fillInMetadata(AshwoodEntitySorter.java: 
>>> 265)
>>> 	at  
>>> org 
>>> .apache 
>>> .cayenne 
>>> .map.AshwoodEntitySorter._indexSorter(AshwoodEntitySorter.java:98)
>>> 	at  
>>> org 
>>> .apache 
>>> .cayenne 
>>> .map.AshwoodEntitySorter.sortDbEntities(AshwoodEntitySorter.java: 
>>> 137)
>>
>> Did anything change in your mapping since the Cayenne update? The  
>> easiest way debug the NPE is to put a breakpoint at the line above  
>> and see why "join.getTarget()" returns null. I suspect a mapping  
>> problem, but don't fully exclude a possibility of a Cayenne bug.
>>
>> Andrus
>>
>


Mime
View raw message