cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <and...@objectstyle.org>
Subject Re: [SOLVED] Re: jpa provider
Date Mon, 17 Dec 2007 21:09:58 GMT
Although ... I am not so sure that it was all that successful, as the  
message is "There are no tests to run."... Never experimented with  
JUnit 4, not sure if the Surefire downgrade resulted in skipping the  
unit tests all together?

Andrus



On Dec 17, 2007, at 10:59 PM, Andrus Adamchik wrote:

> Turned out we've been bitten by this in Cayenne.... This is a  
> surefire Maven plugin bug that breaks the Cayenne agent. Once I  
> added version 2.2 to the plugin declaration I was able to run the  
> test successfully:
>
> ....
> <groupId>org.apache.maven.plugins</groupId>
> <artifactId>maven-surefire-plugin</artifactId>
> <version>2.2</version>
> ....
>
> $ mvn test -Pcayenne
>
>
> [INFO] Surefire report directory: /Users/andrus/Desktop/core/target/ 
> surefire-reports
> *** CayenneAgent starting...
>
> -------------------------------------------------------
> T E S T S
> -------------------------------------------------------
> There are no tests to run.
>
> Results :
> Tests run: 0, Failures: 0, Errors: 0, Skipped: 0
>
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] BUILD SUCCESSFUL
> [INFO]  
> ------------------------------------------------------------------------
>
>
> On Dec 11, 2007, at 7:48 PM, Gilberto C Andrade wrote:
>
>> Would you mind check my project?(attach)
>>
>> Gilberto
>> <core.tar.gz>
>
>


Mime
View raw message