cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <and...@objectstyle.org>
Subject Re: [POLL]: Cayenne 3.0 -- Java 1.4 or 5 support?
Date Fri, 14 Sep 2007 07:12:03 GMT

On Aug 20, 2007, at 4:32 AM, Gilberto Caetano de Andrade wrote:

>
> First I have to say something. It has some time that I have  
> attempted to introduce cayenne here in our department and one of  
> the main arguments that hasimpeded me was the support to the  
> programming with POJO.
>
> But in this first project we are not using this option, being still  
> in phase of learning and mainly for this characteristic not  
> available in version 3.
> But I have to admit, as DBA I find that these characteristics  
> (annotations, POJO, JPA, etc), they do not beat the modeller and  
> the useful technique to avoid overwriting of the custom code.
>
> Thanks for your attention!
>
> Gilberto.
>
> PS.: We will try to switch to Cayenne 2.0.3 and see if the app works.

Hi Gilberto,

There is a revived discussion on the dev list about scheduling the  
Java 5 switch to happen after 3.0M2 release (i.e. 3.0M3 will be Java  
5 only). So I wanted to follow up with you on this. If you weren't  
successful in using 2.0.3 in you app (which I hope you were), one  
more possible option is applying retrotranslator to Cayenne jars:

   http://retrotranslator.sourceforge.net/

Note that I haven't tried this myself, and will be curious to hear  
the results if somebody does.

Cheers,
Andrus

Mime
View raw message