cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <and...@objectstyle.org>
Subject Re: MVN again - now on Dataviews :( !
Date Tue, 31 Jul 2007 09:10:21 GMT
All code dependencies do have explicit versions in the parent pom  
(and maven actually requires version to be present). But Maven  
plugins are considered different beasts and versions are not  
required. If omitted, Maven will fetch the latest version. This  
caused us grief in the past already, so explicitly setting plugin  
versions as well is a good idea.

Andrus


On Jul 31, 2007, at 11:59 AM, Ahmed Mohombe wrote:

>> I hardcoded version of japplication plugin to 2.0.5 - this is the  
>> last version that I personally tested. Try it now.
> Thank you. Now it works :).
>
> If the trick of hardcoding versions does it, wouldn't it make more  
> sense to
> add version for other dependencies as well? I mean generally with  
> mvn, not just for dataviews (in order to prevent future problems -  
> since one can't always test all the latest versions of dependent  
> libs) ?
>
> Thanks in advance,
>
> Ahmed.
>
>


Mime
View raw message