cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tomi NA" <hef...@gmail.com>
Subject Re: modeler, RC1 - misc. feedback
Date Sun, 04 Jun 2006 21:44:48 GMT
On 6/4/06, Andrus Adamchik <andrus@objectstyle.org> wrote:
> My experience is that class generator is actually much more usable in
> B3/RC1 than it was in B2. So I guess some usage scenarios work better
> than others (e.g. I used it extensively on an ROP project, meaning
> standard server and client templates, but rarely with custom
> templates). BTW, before retesting any of these could you please reset
> the preferences by deleting ~/.cayenne/prefs directory, just in case.

I'll see what I can do, but my experimenting time is at the moment
very, very short: I'm limited to reporting what I see as best as I
can.
Update: I just tried it again and now I can't reconstruct the invalid
code generation. I suppose I somhow put the modeler in an anforseen
state yesterday which gave me invalid (and in a couple of variants!)
generated code every time. Today's only run was flawless.

> > * previous code generation behaviour was:
> > a) select a class->generate code-> result: only one class preselected
> > in the code generation dialog
> > b) select a map->generate code-> result: all classes are preselected
> > in the code generation dialog
>
> I think I recognize this issue - will work on it.
>
> > * the modeler can't seem to remember the output directory for code
> > generation, that is, it always appends "cayenne" to an otherwise valid
> > (remembered) directory path
>
> I am not seeing that. Could you open a bug report with some screenshots

I would but I've lost my jira password (tnakic user acc.), used "send
password to e-mail address" and haven't received anything in any of my
inboxes (I can't recall which address I used to open the acc.) If
someone could do something about it (Andrus?), I'd be gratefull - I
don't like opening new accounts because of lost passwords.

> > * I had a lot of problems working with custom code generation
> > templates: once modified, they generated completely invalid
> > (super)classes, sometimes not parsed at all, other times with weird
> > import statements
> >     - the solution? used beta 2 with the same templates, worked
> > like a charm
>
> Also works for me - please log the details in Jira

See first comment. I couldn't repeat the error today.

> > * the template properties dialog doesn't allow modification of
> > existing templates
>
> Can you elaborate?

Sorry, I ment modify as in "allow the user to change the name of the
template". I should have been more clear. An added bonus would be
"open with arbitrary editor" or ad a text editor preference or...well,
I could go on with suggestions. :-)

> > * the template properties dialog doesn't remember the last directory
> > from which the user loaded a template so the user has to navigate the
> > whole path for every template version he uses if he defined a couple
> > of templates in advance (as I did, for example)
>
> Will fix this.
>
> > * the modeler would be *sooo* much more understandable alltogether if
> > it had a tooltip (a sentence or two explaining what the user's looking
> > at) attached to most components, so that users wouldn't have to wonder
> > what e.g. "generation mode: Once per every Entity" means or have to
> > look it up on the Internet.
> > A couple of other examples where tooltips would help are "allow client
> > entities", "[Entity object] Qualifier", "Import EOModel". I could name
> > about several dozens more.
>
> It's been asked by other users recently as well. Won't happen in 1.2,
> but we may do this in the future releases.

Funny, doesn't really seem like a major change, certainly not
technically - if anything, the possibility of breaking current code by
adding tooltips is close to zero. Not that I'm in a hurry, it's just
that I don't know what the problem is. I suppose it isn't as easy as
it seems, writing 100+ thought through explanations about misc.
elements of the modeler...

> > To wash away the aftertaste left behind by such a list of rought
> > edges, I can only say I look forward to developing cayenne-powered
> > apps in the future as well as returning to work on my current
> > cayenne-powered app, now that beta 2 came through where RC1 failed. :)
>
> And you can also recall that 1.1 didn't have most of this
> functionality at all. It is new, and we are still testing it, so
> thanks for the feedback - we will certainly fix all these wrinkles.

I've been using 1.2 so long now it's hard to recall a time when there
was anything else. :) Of course, I started using cayenne just a couple
of months before 1.2 appeard on the horizon.

t.n.a.

Mime
View raw message