cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <and...@objectstyle.org>
Subject Re: toMany relationship not fetched
Date Sat, 08 Apr 2006 10:34:35 GMT
Marcin,

I ported your test to B1 and ran it on my machine - it works without  
any errors. Can you confirm whether this is still a problem?

BTW, I noticed one minor thing in the mapping - you should not  
populate "Client Superclass" field. This field is for the "wedge"  
class that may optionally be inserted in the inheritance hierarchy  
between cayenne.Persistent and _MyObject.

Andrus


On Mar 28, 2006, at 2:49 AM, Marcin Skladaniec wrote:

> Hello
> I tried with cayenne 1.2M12 but have the same problem.
> Here is a small project based on the 3t example from sandbox
> reproducing the malfunction I'm seeing. (http:// 
> smokidwa.freeshell.org/work/test.zip)
> all jars needed to run project are on http://smokidwa.freeshell.org/ 
> work/
> Marcin
>
> On 27/03/2006, at 5:56 PM, Tore Halset wrote:
>
>> On Mar 19, 2006, at 23:48, Marcin Skladaniec wrote:
>>
>>> I created a brand new project and I'm still having this problem.  
>>> Double-checked out the relations, the data types are matching.
>>> I have done some more testing and found that one-to-many and many- 
>>> to-many flattened relations work. That is only many-to-one that  
>>> not works.
>>> What else can be wrong ?
>>
>> Can you create a small test-project to reproduce this behaviour?  
>> It will make it easier for us to help out.
>>
>>  - Tore.
>
> -------------------------->
> ish
> http://www.ish.com.au
> Level 1, 30 Wilson Street Newtown 2042 Australia
> phone +61 2 9550 5001   fax +61 2 9550 4001
>
>
>


Mime
View raw message