cayenne-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Kienenberger" <mkien...@gmail.com>
Subject Re: [solved] Re: Cayenne.xml not found.
Date Tue, 04 Apr 2006 14:20:24 GMT
On 4/4/06, WONDER <mmmmmmmmm53@web.de> wrote:
> The application is too complicated.
> I am prity sure adding the XMLs to the jar file "should" work, but it does
> not.
> I use custom framework and the class which call the Cayenne.xml is there.

I think part of the problem is that you're trying to do too many things at once.
If I recall, you not only want to integrate Cayenne with WebObjects,
but you are also trying to  use a package name for all of your xml
files.

I think you'd be better off getting Cayenne working with Webobjects in
the default configuration first, then trying to add the packaging of
your xml files.

I posted how you'd get the packaging to work in a previous message.
Dropping your xml files in your src directory should be all that's
needed to get them into your class package, provided your build script
then copies them over into your classes directory or jar file.

Are you sure that your appName.jar is read out of Resources/Java?   In
my WO 5.2 project, I have a WEB-INF/classes directory that I use
instead of a jar file.   Looking at my Resources/Java/*.jar file, I
see that it's empty.

You don't want to use something like this "c:/myPath/Cayenne.xml"
because it won't work when you go to deploy your application on an
application server.

Mime
View raw message