cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nikita Timofeev <ntimof...@objectstyle.com>
Subject Re: [VOTE] Apache Cayenne 4.2.M1 release
Date Fri, 03 Apr 2020 11:57:00 GMT
Hi all,

I've rolled back 4.2.M1 release and will start new voting soon.
Fix for the meaningful FK is committed now [1].
I've also checked that the latest snapshot version of the Apache RAT
[2] is ok with the "https://", so we could use it.
I'll update docs and also will mention the maven plugin.

John, could you please check again your meaningful FK test case with
the latest cayenne snapshot build?

[1] https://issues.apache.org/jira/browse/CAY-2652
[2] https://repository.apache.org/content/repositories/snapshots/org/apache/rat/apache-rat/

On Sat, Mar 28, 2020 at 1:04 AM John Huss <johnthuss@gmail.com> wrote:
>
> Thanks.
>
> I figured out the problem with cgen was that I had velocity-engine-core-2.0
> instead of velocity-engine-core-2.1. Updating the jar fixed the problem.
>
>
> On Thu, Mar 26, 2020 at 12:25 PM Nikita Timofeev <ntimofeev@objectstyle.com>
> wrote:
>
> > Thank you, John, for your thorough testing.
> >
> > 1. Seems like RAT don't like the change from "http://" to "https://"
> > in the license text. I've updated settings for the RAT maven plugin
> > (as I use it to check sources) and that works ok. Need to update
> > config for the standalone script.
> > 2. Cgen + ant. IIRC we had some problems with that and you helped a
> > lot with it. I've tested cgen task in a simple demo project and it
> > works fine for me, but I don't really know much about the Ant.
> > If you can create a demo project or help somehow else, that would be great.
> > 3. I was able to reproduce this one. Primitive type in the meaningful
> > FK really creating problems, so need to fix this.
> >
> > I'll keep this vote open in case something else comes up.
> >
> > On Thu, Mar 26, 2020 at 1:05 AM John Huss <johnthuss@gmail.com> wrote:
> > >
> > > Thanks for all your work on this. 4.2 is going to be a great release! I
> > ran
> > > all my checks on the release and almost everything passed.
> > >
> > > I don't know what changed, but I'm having a RAT problem I haven't seen
> > > before. RAT (both 0.12 and 0.13) show this header:
> > >
> > > Printing headers for text files without a valid license header...
> > >
> > >
> > > then lists basically every source file in the archive, example below.
> > When
> > > I open this file directly the license header is there, but the printout
> > > from RAT doesn't show it.
> > >
> > > =====================================================
> > >
> > > == File:
> > >
> > cayenne-4.2.M1-src/cayenne-osgi/src/test/java/org/apache/cayenne/configuration/osgi/OsgiClassLoaderManagerTest.java
> > >
> > > =====================================================
> > >
> > > /*****************************************************************
> > >
> > >  *
> > >
> > >  *
> > >
> > >  ****************************************************************/
> > >
> > > package org.apache.cayenne.configuration.osgi;
> > >
> > >
> > > import org.junit.Test;
> > >
> > >
> > > import java.util.Collections;
> > >
> > >
> > > import static org.junit.Assert.assertSame;
> > >
> > > import static org.mockito.Mockito.mock;
> > >
> > >
> > > public class OsgiClassLoaderManagerTest {
> > >
> > >
> > >
> > >
> > -----------------------------------------------------------------------------------------------------------------------------
> > > More importantly, I'm seeing some issues with cgen (using ant) not
> > finding
> > > templates. This wasn't happening when I tested 4.2 months ago, so it must
> > > be a more recent change.
> > >
> > > org.apache.velocity.exception.ResourceNotFoundException: Unable to find
> > > resource 'templates/v4_1/superclass.vm'
> > >
> > >
> > > <target name="generate_java">
> > >
> > > <cgen map="src/MyApp.map.xml"
> > >
> > > superpkg="com.myapp.auto"
> > >
> > > createpropertynames="true"
> > >
> > > destDir="src"
> > >
> > > outputPattern="*.java"
> > >
> > > usepkgpath="true"
> > >
> > > encoding="UTF-8"
> > >
> > > mode="all"
> > >
> > > force="true"
> > >
> > > />
> > >
> > > </target>
> > >
> > >
> > >
> > > The unit tests in my projects are looking nearly perfect. But I did see a
> > > regression in a very specific case. I have an entity with a meaningful
> > > foreign key attribute that is modeled as a primitive (int). The attribute
> > > is the same column as referenced by a relationship on the same entity.
> > This
> > > was working in the previous version but isn't working now. The value is
> > > just always zero for this field now. I'm not sure if this is supposed to
> > be
> > > supported.
> > >
> > >
> > > On Tue, Mar 24, 2020 at 4:55 AM Nikita Timofeev <
> > ntimofeev@objectstyle.com>
> > > wrote:
> > >
> > > > Hi all,
> > > >
> > > > Here is a long-awaited 4.2.M1 release.
> > > > JIRA tells that it has impressive 100 issues resolved.
> > > >
> > > > Release notes:
> > > > https://github.com/apache/cayenne/blob/4.2.M1/RELEASE-NOTES.txt
> > > > Maven repo:
> > > >
> > https://repository.apache.org/content/repositories/orgapachecayenne-1037/
> > > > Assemblies: https://dist.apache.org/repos/dist/dev/cayenne/4.2.M1/
> > > >
> > > > Please evaluate and cast your votes.
> > > >
> > > > --
> > > > Best regards,
> > > > Nikita Timofeev
> > > >
> >
> >
> >
> > --
> > Best regards,
> > Nikita Timofeev
> >



-- 
Best regards,
Nikita Timofeev

Mime
View raw message