cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Gentry <blackn...@gmail.com>
Subject Re: Java 8
Date Wed, 26 Jul 2017 14:23:09 GMT
BTW, it would be better to bring this up on the user list than the
developer list since it has more subscribers and they are the users of
Cayenne, not the developers of Cayenne.

I still don't expect opposition, but it is the better place to discuss this
requirement.

Thanks,

mrg


On Wed, Jul 26, 2017 at 5:52 AM, Nikita Timofeev <ntimofeev@objectstyle.com>
wrote:

> Hi all,
>
> I think it is time to drop support for Java 7 in 4.1.
>
> Java 7 has reached EOL couple years ago and Java 9 will be there in
> this September, so I think support for new Java version is more
> important, and that is not fully possible without dropping Java 7 (at
> least it's impossible to have compatibility with 7,8 and 9 for MacOS
> version of the Modeler).
>
> Meanwhile Cayenne 4.0 that supports Java 7 is not even final and will
> be supported for some time, so I don't see any reasons why we
> shouldn't do this.
>
> --
> Best regards,
> Nikita Timofeev
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message