cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <and...@objectstyle.org>
Subject Re: Reg | 'mvn cayenne-modeler:run' command still broken in 4.0.M5
Date Fri, 10 Feb 2017 07:48:29 GMT
Ok, per Nikita's comment in Jira, we can actually fix it by renaming the plugin. Nice!

https://issues.apache.org/jira/browse/CAY-1980?focusedCommentId=15860865&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-15860865

Andrus

> On Feb 10, 2017, at 3:02 PM, Andrus Adamchik <andrus@objectstyle.org> wrote:
> 
> So looking at this doc [1], it appears that we as plugin developers can't do much about
it. Our plugins are outside of "org.apache.maven.plugins" group, so our prefix will not resolve
by default. Instead Maven requires each user to edit their ~/.m2/settings.xml to add extra
groups whose prefixes are to be resolved.
> 
> (I guess we need to add this bit to the docs).
> 
> Andrus
> 
> [1] https://maven.apache.org/guides/introduction/introduction-to-plugin-prefix-mapping.html
> 
> 
> 
>> On Feb 10, 2017, at 7:22 AM, Sarva Ratchagan <sarvaratchagan@outlook.com> wrote:
>> 
>> Hi Gang,
>> 
>>    I just want make sure this "mvn cayenne-modeler:run" command working for all community
developers or not. Because when I try to run cayenne modeler from my local environment It
seems to be broken. I hope this issue already raised & fixed by Andrus. I can see some
log against this issue in Jira. 
>> 
>> Please refer this link.
>> 
>>   https://issues.apache.org/jira/browse/CAY-1980
>> 
>> When I run this command, this is what I'm getting here.
>> 
>> 
>> 
>> 
>> Can anyone tell me why?
>> 
>> 
>> At the same time if I try with "mvn org.apache.cayenne.plugins:maven-cayenne-modeler-plugin:4.0.M5-SNAPSHOT:run"
this command Its working perfect.
>> 
>> 
>> Thanks -
>> Sarva
> 


Mime
View raw message