cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nikita Timofeev <ntimof...@objectstyle.com>
Subject Re: Build failure
Date Fri, 23 Dec 2016 09:29:46 GMT
Hi all,

Turned out that Postgres never been tested on JDK7 with current JDBC driver
as it is for Java 8 only.
Here is pull request with correct driver version:
https://github.com/apache/cayenne/pull/171


On Fri, Dec 23, 2016 at 9:27 AM, Andrus Adamchik <andrus@objectstyle.org>
wrote:

> Yeah, and it looks like this is the problem in Cayenne master code (recent
> enabling of Postgres Docker profile didn't take Java 7 into account). E.g.:
> https://travis-ci.org/apache/cayenne/builds/186072226
>
> Nothing wrong with the PR. In fact I just merged it.
>
> Andrus
>
> > On Dec 22, 2016, at 9:44 PM, Mike Kienenberger <mkienenb@gmail.com>
> wrote:
> >
> > One of the classes (probably from the postgres driver) was compiled with
> a
> > java version higher than what is running the build.
> >
> >
> > On Thu, Dec 22, 2016 at 1:26 PM, buddha <jyothiprasadb@gmail.com> wrote:
> >
> >> Hi,
> >>
> >>
> >>
> >> I’m just trying to make a small commit which is a fix in two small xml
> >> files that generate html files for documentation. Created a pull
> >> request(#170), however continuous integration is failing. The change I
> did
> >> has nothing to do with the failure of the build. Build is failing with
> >> (Caused by: java.lang.UnsupportedClassVersionError:
> org/postgresql/Driver
> >> : Unsupported major.minor version 52.0)
> >>
> >>
> >>
> >> https://travis-ci.org/apache/cayenne/builds/186140745
> >>
> >>
> >>
> >> Can someone help me out as to what the issue is?
> >>
> >>
> >>
> >> Thanks
> >>
> >> Buddha
> >>
> >>
>
>


-- 
Best regards,
Nikita Timofeev

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message