cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <and...@objectstyle.org>
Subject Re: [VOTE] 3.1.1
Date Tue, 10 May 2016 17:24:27 GMT
Hi Mike,

Great research. At least we know that nothing is broken at the source level.

Andrus

> On May 10, 2016, at 6:38 AM, Michael Gentry <blacknext@gmail.com> wrote:
> 
> So, my final bit of investigation (unless anyone thinks of anything else):
> 
> Fedora 23 + OpenJDK 8 + build Cayenne 3.1.1 source bundle: CM works
> 
> For whatever reason, the binary distribution doesn't work with OpenJDK 8 on
> Fedora, but if you compile the source with OpenJDK 8, you'll have a working
> CM.  We should just be aware of this in case someone is having an issue.
> We can tell them two solutions: compile CM yourself with OpenJDK 8 or use
> Oracle's JDK.
> 
> Thanks,
> 
> mrg
> 
> 
> On Mon, May 9, 2016 at 4:03 PM, Michael Gentry <blacknext@gmail.com> wrote:
> 
>> Fedora 23 + Oracle JDK 1.8.0_92: CM runs
>> Fedora 23 + Open JDK 1.8.0_91: CM crashes
>> Linux Mint 17.3 Cinnamon + Open JDK 1.7.0_101: CM runs
>> 
>> I'm assuming it'll run on Ubuntu as well, since Mint is based upon Ubuntu
>> and Ubuntu uses JDK 7 if memory serves.
>> 
>> So, at first glance, seems to be some compatibility issue with OpenJDK 8 +
>> CM.
>> 
>> mrg
>> 
>> 
>> On Mon, May 9, 2016 at 3:06 PM, Michael Gentry <blacknext@gmail.com>
>> wrote:
>> 
>>> I'm pretty sure Mint uses OpenJDK, too, but I believe it comes with Java
>>> 7 instead of Java 8. I'll investigate, including Oracle, and report back.
>>> 
>>> Thanks,
>>> 
>>> mrg
>>> 
>>>> On May 9, 2016, at 11:31 AM, Andrus Adamchik <andrus@objectstyle.org>
>>> wrote:
>>>> 
>>>> Would it be possible to try it on Oracle Java? Could be an OpenJDK bug.
>>>> 
>>>> Andrus
>>>> 
>>>>> On May 9, 2016, at 7:36 AM, Michael Gentry <blacknext@gmail.com>
>>> wrote:
>>>>> 
>>>>> For grins, I installed Mint and Fedora in VirtualBox.  Cayenne Modeler
>>> runs
>>>>> in Mint, but not Fedora.
>>>>> 
>>>>> Here is the exception:
>>>>> 
>>>>> [mrg@localhost cayenne-3.1.1]$ java -jar bin/CayenneModeler.jar
>>>>> May 09, 2016 10:31:55 AM org.apache.cayenne.modeler.util.ModelerLogger
>>> info
>>>>> INFO: Starting CayenneModeler.
>>>>> May 09, 2016 10:31:56 AM org.apache.cayenne.modeler.util.ModelerLogger
>>> info
>>>>> INFO: JRE v.1.8.0_91 at
>>>>> /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.91-2.b14.fc23.x86_64/jre
>>>>> Exception in thread "main" java.lang.ExceptionInInitializerError
>>>>> at
>>>>> 
>>> com.jgoodies.looks.plastic.PlasticLookAndFeel.<clinit>(PlasticLookAndFeel.java:122)
>>>>> at
>>>>> 
>>> org.apache.cayenne.modeler.generic.GenericPlatformInitializer.findTheme(GenericPlatformInitializer.java:64)
>>>>> at
>>>>> 
>>> org.apache.cayenne.modeler.generic.GenericPlatformInitializer.initLookAndFeel(GenericPlatformInitializer.java:48)
>>>>> at org.apache.cayenne.modeler.Main.launch(Main.java:79)
>>>>> at
>>> org.apache.cayenne.modeler.generic.GenericMain.main(GenericMain.java:33)
>>>>> Caused by: java.awt.HeadlessException
>>>>> at
>>> sun.awt.HeadlessToolkit.getScreenResolution(HeadlessToolkit.java:226)
>>>>> at com.jgoodies.looks.LookUtils.isLowResolution(LookUtils.java:436)
>>>>> at com.jgoodies.looks.LookUtils.<clinit>(LookUtils.java:180)
>>>>> ... 5 more
>>>>> 
>>>>> 
>>>>> Does anyone have Fedora (or Red Hat) they can test Cayenne Modeler
>>> on?  It
>>>>> could be an issue with VirtualBox.  I used Fedora 23, Java 8 (as you
>>> can
>>>>> see in the stack trace), and 1920x1080 monitor resolution.
>>>>> 
>>>>> Thanks,
>>>>> 
>>>>> mrg
>>>>> 
>>>>> 
>>>>> 
>>>>>> On Sat, May 7, 2016 at 2:42 PM, Michael Gentry <blacknext@gmail.com>
>>> wrote:
>>>>>> 
>>>>>> Given other's feedback, ignoring the .iml files.
>>>>>> 
>>>>>> 
>>>>>> The following generated files were missing a license header:
>>>>>> 
>>>>>> 
>>>>>> 
>>> framework/cayenne-jdk1.5-unpublished/src/main/java/org/apache/cayenne/exp/parser/ExpressionParserTreeConstants.java
>>>>>> 
>>>>>> 
>>> framework/cayenne-jdk1.5-unpublished/src/main/java/org/apache/cayenne/exp/parser/JJTExpressionParserState.java
>>>>>> 
>>>>>> We have the license header in other generated files, such as:
>>>>>> 
>>>>>> 
>>>>>> 
>>> framework/cayenne-jdk1.5-unpublished/src/main/java/org/apache/cayenne/exp/parser/Token.java
>>>>>> 
>>>>>> I don't think this is a big issue, but thought I'd mention it.  No
>>> idea if
>>>>>> it can be easily added and even if so, I'd not hold up a release
on it
>>>>>> since they are generated files.
>>>>>> 
>>>>>> This one is also missing a license header, which also is probably
not
>>>>>> significant:
>>>>>> 
>>>>>> 
>>>>>> 
>>> itests/cayenne-tools-itest/src/test/resources/org/apache/cayenne/tools/velotemplate.vm
>>>>>> 
>>>>>> 
>>>>>> Outside of that:
>>>>>> 
>>>>>> 1) All artifacts download.
>>>>>> 2) MD5 checksums are valid.
>>>>>> 3) Signatures are valid.
>>>>>> 4) OS X DMG mounts and is valid and Cayenne Modeler runs.
>>>>>> 5) Linux binary extracts and Cayenne Modeler runs.
>>>>>> 6) rat passes (mostly, see above)
>>>>>> 7) JDK7 builds.
>>>>>> 8) JDK8 builds.
>>>>>> 9) Cayenne Modeler runs from built sources (OS X and Linux).
>>>>>> 
>>>>>> +1
>>>>>> 
>>>>>> 
>>>>>> Thanks,
>>>>>> 
>>>>>> mrg
>>>>>> 
>>>>>> 
>>>>>> 
>>>>>> On Fri, Apr 29, 2016 at 12:04 PM, Savva Kolbachev <
>>> s.kolbachev@gmail.com>
>>>>>> wrote:
>>>>>>> 
>>>>>>> Hi All,
>>>>>>> I'm glad to tell you that I've prepared 3.1.1 artifacts for voting.
>>>>>>> 
>>>>>>> Maven artifacts:
>>>>>> 
>>> https://repository.apache.org/content/repositories/orgapachecayenne-1010/
>>>>>>> Assemblies:
>>>>>>> https://dist.apache.org/repos/dist/dev/cayenne/cayenne-parent-3.1.1/
>>>>>>> 
>>>>>>> Please evaluate and cast your votes.
>>>>>>> 
>>>>>>> --
>>>>>>> Thanks and Regards
>>>>>>> Savva Kolbachev
>>>> 
>>> 
>> 
>> 


Mime
View raw message