cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Kolonitsky <akolonit...@objectstyle.com>
Subject Re: [VOTE] 4.0.M2
Date Wed, 25 Feb 2015 11:12:44 GMT
Hi all
I've just found that we still have dependency on GPL library in tests (org.fluttercode.datafactory:datafactory)
We postpone voting until I fix this issue and rebuild all release artifacts.


> On Feb 25, 2015, at 2:45 AM, Aristedes Maniatis <ari@maniatis.org> wrote:
> 
> On 24/02/2015 4:21am, Andrus Adamchik wrote:
>> These we need to fix. So I am temporarily -1. Let's add those licenses and re-publish
the release (and while we are at it, we might fix #1 as well).
> 
> 
> I think that we perhaps need to pause and understand what it is we are releasing. I appreciate
the considerable development work being put in at the moment, particularly by Alex, Savva
and yourself. But a lot of that work is not being discussed on this list, so I'm a little
confused about exactly where we got to with the new API and other features for 4.0.
> 
> 1. Are we looking for a milestone release which will contain a fully finished API?
> 
> 2. What are we asking users to review and give us feedback on?
> 
> 3. What is our policy on removing bits of the API between 4.0M2 and 4.0M3 if we decide
we don't like something?
> 
> 4. What is the state of the documentation to show users how to use the new API? I took
a look and couldn't find anything other than the javadocs.
> 
> I am all in favour of releasing much more often, but I think we should be clear about
what this release is there to achieve.
> 
> Ari
> 
> 
> 
> -- 
> -------------------------->
> Aristedes Maniatis
> GPG fingerprint CBFB 84B4 738D 4E87 5E5C  5EFA EF6A 7D2E 3E49 102A
> 


Mime
View raw message