cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Kienenberger <mkien...@gmail.com>
Subject Re: Java 1.7 for 4.0 .. again
Date Sun, 26 Oct 2014 18:46:56 GMT
 J2EE 6 is still mainstream, and J2EE 7 is still relatively unsupported
(J2EE 7 is also only a 1.5 years old).

http://en.wikipedia.org/wiki/Java_Platform,_Enterprise_Edition#Certified_application_servers

On Sun, Oct 26, 2014 at 9:05 AM, Andrus Adamchik <andrus@objectstyle.org>
wrote:

> So quite a bit of time has passed since our last Java 7 discussion. Java 6
> is even more distant memory now. Of which I was reminded today after I
> upgraded my laptop to Yosemite. My Modeler instance wouldn't start without
> installing "legacy Java SE 6 runtime" (of course I quickly switched to Java
> 7 modeler and all was good). So I suggest two things, both applying to
> Cayenne 4.0 (aka 3.2) :
>
> 1. Make Java 1.7 a minimal requirement.
> 2. If #1 meets any opposition, at least stop supporting Java 6 friendly
> Modeler assembly on the Mac, which existence has no reasonable excuse
> anymore.
>
> Andrus
>
>
>

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message