cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <and...@objectstyle.org>
Subject Re: cayenne 3.1 B3 dependencies missing commons-lang-2.6
Date Wed, 18 Dec 2013 06:53:23 GMT
Cayenne does not have commons-lang dependency. I think it is a dependency of Velocity. Velocity
1.6.3 depends on commons-lang 2.4 (and also oro 2.0.8 - why in the world people would still
use oro?)

So commons-lang will be needed if you are running SQLTemplate and EJBQL queries (that are
using Velocity). Yeah, I think we need to somehow address that either in the docs and/or by
packaging those in third-party/ .. 

I also wish we reduce / remove our dependency on Velocity. Then we’ll be pretty close to
dependency-free holy grail for a typical user :)

A.

On Dec 18, 2013, at 6:08 AM, Mike Kienenberger <mkienenb@gmail.com> wrote:
> This was on the windows distribution.  I haven't checked the other ones.
> 
> On Tue, Dec 17, 2013 at 10:07 PM, Mike Kienenberger <mkienenb@gmail.com> wrote:
>> We state:
>> 
>> =============
>> 
>> When using cayenne-server-x.x.jar you'll need a few third party jars
>> (all included in lib/third-party directory of the distribution):
>> 
>> Apache Velocity Template Engine, version 1.6.x (and all its
>> dependencies bundled with velocity-dep)
>> 
>> Apache Commons Collections, version 3.2.1
>> 
>> Apache Commons Logging, version 1.1
>> =============
>> 
>> http://cayenne.apache.org/docs/3.1/cayenne-guide/including-cayenne-in-project.html#jar-files-and-depdendencies
>> 
>> However, we are missing commons-lang-2.6
> 


Mime
View raw message