cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <and...@objectstyle.org>
Subject Re: Minimal Java version for each release?
Date Mon, 18 Nov 2013 06:06:57 GMT
As it stands right now, we have the following JVM requirements:

Cayenne 3.2 - Java 1.6
Cayenne 3.1 - Java 1.5
Cayenne 3.0 - Java 1.5

We sorta mention it inside user guide [1]. But yeah, having it more pronounced, like Jetty
does [2] would certainly be better. In 3.2 “System Requirements” chapter has a full compatibility
table. Just that we haven’t published it to the site yet.

Andrus

[1] http://cayenne.apache.org/docs/3.1/cayenne-guide/setup.html#system-requirements
[2] http://www.eclipse.org/jetty/documentation/current/what-jetty-version.html

On Nov 17, 2013, at 10:39 PM, Adrian A. <a.adrian.tech@googlemail.com> wrote:
> Hi,
> 
> would be quite useful if on the Download page (or somewhere else)
> would be listed what minimal Java version is required for each release
> (mostly for the server), since very often the Java version a critical
> constraint for adoption.
> 
> Thanks in advance.
> 
> Adrian.
> 


Mime
View raw message