cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <and...@objectstyle.org>
Subject Re: Oddity...
Date Fri, 19 Jul 2013 10:59:24 GMT
You might be on to something here… IIRC there is a window positioning code in the Modeler.
Wonder if the second monitor causes it to go off screen?

Andrus

On Jul 18, 2013, at 1:39 PM, Tony Giaccone <tgiaccone@gmail.com> wrote:

> And yet no window displays. A icon shows up in the dock. I wonder do you have two monitors?
Is it possible that something with that configuration is causing this oddity?
> 
> Tony
> 
> On Jul 18, 2013, at 2:33 AM, Andrus Adamchik <andrus@objectstyle.org> wrote:
> 
>> To me this doesn't look any different from a successfully started app.
>> 
>> On Jul 17, 2013, at 11:06 PM, Tony Giaccone <tgiaccone@gmail.com> wrote:
>> 
>>> Here's the output of the jstack..
>>> 
>>> 
>>> 
>>> 
>>> On Wed, Jul 17, 2013 at 3:52 PM, Andrus Adamchik <andrus@objectstyle.org>
wrote:
>>> You could try "jstack <pid>" to see what's happening if the app is still
alive.
>>> 
>>> On Jul 17, 2013, at 10:41 PM, Tony Giaccone <tgiaccone@gmail.com> wrote:
>>> 
>>>> I'm guessing it has something to do with my install of the JDK/JRE
>>>> 
>>>> is there an easy way to increase the logging so I can see where the app is
hanging??
>>>> 
>>>> Tony
>>>> 
>>>> On Jul 17, 2013, at 3:28 PM, Andrus Adamchik <andrus@objectstyle.org>
wrote:
>>>> 
>>>>> Odd indeed.
>>>>> 
>>>>> I have Centos5.5 here running on VirtualBox. Just tried it… I can start
3.1B2 Modeler with either OpenJDK or Oracle Java (both 1.7.0_25). Logged in under root, but
really hope that shouldn't matter… CayenneModeler won't attempt to write anywhere outside
$HOME.
>>>>> 
>>>>> Andrus
>>>>> 
>>>>> 
>>>>> 
>>>>> On Jul 17, 2013, at 9:37 PM, Tony Giaccone <tgiaccone@gmail.com>
wrote:
>>>>> 
>>>>>> 
>>>>>> New Job, new environment.
>>>>>> 
>>>>>> I've been handed a new laptop running Ubuntu 13 (64 bit) I've installed
open jdk 7 and downloaded cayenne 3.0.2 and 3.1B2
>>>>>> 
>>>>>> I start the modeler at the command line.
>>>>>> 
>>>>>> $ java -jar CayenneModeler.jar
>>>>>> 
>>>>>> 3.0.2 works like a charm.
>>>>>> 
>>>>>> 3.1B2 hangs after emitting four lines.
>>>>>> 
>>>>>> Jul 17, 2013. org.apache.cayenne.modeler.util.ModelerLogger info
>>>>>> INFO: Starting Cayenne Modeler.
>>>>>> Jul 17, 2013. org.apache.cayenne.modeler.util.ModelerLogger info
>>>>>> INFO: JRE v.1.7.0_25 at /usr/lib/jvm/java-7-openjdk-amd64/jre
>>>>>> 
>>>>>> Nothing more..
>>>>>> 
>>>>>> I copied those lines by hand as I'm writing this on my iPhone.
>>>>>> 
>>>>>> Any suggestions as to why this is happening. Or how to get more detailed
info a out what is happening?
>>>>>> 
>>>>>> 
>>>>>> Tony
>>> 
>>> 
>>> <stack.txt>
>> 
> 


Mime
View raw message