cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Gentry <mgen...@masslight.net>
Subject Re: [VOTE] 3.2M1 - take 2
Date Mon, 15 Jul 2013 13:08:51 GMT
OK, a +1 from me (I'm assuming my Mac is just having a Java glitch).

BTW, I built Cayenne Modeler from the source download using Java 6 and
7 and both ran fine.  It is just the DMG version that trolls me.

Thanks,

mrg


On Mon, Jul 15, 2013 at 8:07 AM, Andrus Adamchik <andrus@objectstyle.org> wrote:
>> PS. I can just skip the OS X stuff and do the rest of the evaluation.
>
> Probably at this point this is the best option :-/
>
> On Jul 15, 2013, at 2:51 PM, Michael Gentry <mgentry@masslight.net> wrote:
>
>> [07:47:10] ~/Projects/Eclipse/3.2-Release> /usr/libexec/java_home -V
>> Matching Java Virtual Machines (4):
>>    1.7.0_25, x86_64: "Java SE 7"
>> /Library/Java/JavaVirtualMachines/jdk1.7.0_25.jdk/Contents/Home
>>    1.7.0_07, x86_64: "Java SE 7"
>> /Library/Java/JavaVirtualMachines/jdk1.7.0_07.jdk/Contents/Home
>>    1.6.0_51-b11-456, x86_64: "Java SE 6"
>> /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
>>    1.6.0_51-b11-456, i386: "Java SE 6"
>> /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
>>
>> /Library/Java/JavaVirtualMachines/jdk1.7.0_25.jdk/Contents/Home
>>
>> [07:47:22] ~/Projects/Eclipse/3.2-Release> /usr/libexec/java_home
>> /Library/Java/JavaVirtualMachines/jdk1.7.0_25.jdk/Contents/Home
>>
>> Cayenne Modeler *does* run, just not the one distributed in the DMG.
>> I built CM from the source distribution using "/usr/bin/mvn clean
>> install -Passembly,mac" and it runs fine, so I don't think it is an
>> issue with choosing the Java version.
>>
>> mrg
>>
>> PS. I can just skip the OS X stuff and do the rest of the evaluation.
>>
>>
>> On Sun, Jul 14, 2013 at 3:51 PM, Andrus Adamchik <andrus@objectstyle.org> wrote:
>>> BTW, Mike, do you have both Java 6 & 7, or just 7? E.g. here is what I have
on my machine:
>>>
>>> ~: /usr/libexec/java_home -v 1.7
>>> /Library/Java/JavaVirtualMachines/jdk1.7.0_25.jdk/Contents/Home
>>>
>>> ~: /usr/libexec/java_home -v 1.6
>>> /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
>>>
>>> ~: java -version
>>> java version "1.7.0_25"
>>> Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
>>> Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)
>>>
>>> (and the Modeler somehow still picks Java 6)
>>>
>>> Andrus
>>>
>>> On Jul 14, 2013, at 9:30 PM, Andrus Adamchik <andrus@objectstyle.org> wrote:
>>>
>>>> I suspect OS X already cached some information associated with this particular
download on your machine.
>>>>
>>>> Not sure how we get out of a bind with the release vote here? Maybe you take
the release "src" assembly (which is from the ASF perspective is the only thing that matters
in a release; of course the end users may have a different opinion :)), build an OS X assembly
from it locally, and test the Modeler based on your build? Not ideal, bit without having a
clue as to the nature of the Modeler failures not sure what else we can do.
>>>>
>>>> Andrus
>>>>
>>>>
>>>> On Jul 14, 2013, at 6:15 PM, Michael Gentry <mgentry@masslight.net>
wrote:
>>>>> I've rebooted, downloaded using different browsers, and tried Ari's
>>>>> trick of docking the modeler/etc, but still no luck running it from
>>>>> the distribution copy (the one I built locally runs).  I suppose it
>>>>> could just be my system and if so, I'll be neutral on the release.  My
>>>>> system is up-to-date:
>>>>>
>>>>> [11:05:18] ~/Projects/Eclipse/3.2-Release> java -version
>>>>> java version "1.7.0_25"
>>>>> Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
>>>>> Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)
>>>>>
>>>>> And I'm on 10.8.4, just like Andrus.
>>>>>
>>>>> mrg
>>>>>
>>>>> On Sun, Jul 14, 2013 at 4:53 AM, Aristedes Maniatis <ari@maniatis.org>
wrote:
>>>>>> Yes, I see the same random behaviour with another of my projects.
Only on
>>>>>> OSX and there is no discernable pattern. A workstation will fail
in just
>>>>>> that way. But then you can drag the app to the Dock and run it from
there
>>>>>> just fine. After you do that, the original app might then be double
>>>>>> clickable again.
>>>>>>
>>>>>> I am pretty sure this is just a runtime OSX/Java oddity and nothing
to do
>>>>>> with the build itself being broken. We have seen it happen less often
since
>>>>>> our machines moved to Java 7.
>>>>>>
>>>>>>
>>>>>>
>>>>>> Ari
>>>>>>
>>>>>>
>>>>>>
>>>>>> On 14/07/13 1:48am, Andrus Adamchik wrote:
>>>>>>>
>>>>>>> I recall one of my colleagues ran into a similar unexplainable
behavior
>>>>>>> with a newly downloaded Modeler about a year ago. That was a
version of
>>>>>>> Cayenne that was current back then. We went through a bunch of
random
>>>>>>> motions - reboots, re-downloads, and eventually it worked. Also
couldn't
>>>>>>> figure out the cause… I attribute it to some OS X bug.
>>>>>>>
>>>>>>> Andrus
>>>>>>>
>>>>>>> On Jul 13, 2013, at 6:13 PM, John Huss <johnthuss@gmail.com>
wrote:
>>>>>>>
>>>>>>>> Both worked for me as well.
>>>>>>>>
>>>>>>>> On Saturday, July 13, 2013, Andrus Adamchik wrote:
>>>>>>>>
>>>>>>>>> This is very odd. I just downloaded a fresh copy via
FireFox, and it
>>>>>>>>> opens
>>>>>>>>> just fine on my laptop (after expected warnings about
opening downloaded
>>>>>>>>> software for the first time). Also both from mounted
image and from
>>>>>>>>> Desktop. I have OS X 10.8.4.
>>>>>>>>>
>>>>>>>>> Andrus
>>>>>>>>>
>>>>>>>>> On Jul 13, 2013, at 5:28 PM, Michael Gentry
>>>>>>>>> <mgentry@masslight.net<javascript:;>>
>>>>>>>>> wrote:
>>>>>>>>>
>>>>>>>>>> FWIW, I just built the OS X assembly and it runs
fine (HD and DMG),
>>>>>>>>>> but the downloaded version didn't for some reason.
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> On Sat, Jul 13, 2013 at 9:53 AM, Michael Gentry
>>>>>>>>>> <mgentry@masslight.net<javascript:;>>
>>>>>>>>>
>>>>>>>>> wrote:
>>>>>>>>>>>
>>>>>>>>>>> -1
>>>>>>>>>>>
>>>>>>>>>>> MD5 for OS X DMG is correct, but Cayenne Modeler
fails to launch from
>>>>>>>>>>> both the mounted disk image and the HD (copied
from the disk image)
>>>>>>>>>>> with the following alert:
>>>>>>>>>>>
>>>>>>>>>>> “CayenneModeler.app” is damaged and can’t
be opened. You should move
>>>>>>>>>>> it to the Trash.
>>>>>>>>>>> Safari downloaded this file today at 9:37 AM
from people.apache.org.
>>>>>>>>>>>
>>>>>>>>>>> The console didn't provide anything useful when
canceling the alert:
>>>>>>>>>>>
>>>>>>>>>>> 7/13/13 9:50:23.601 AM com.apple.launchd.peruser.501[342]:
>>>>>>>>>>> ([0x0-0x35c35c].CayenneModeler[6610]) Exited:
Killed: 9
>>>>>>>>>>>
>>>>>>>>>>> I'm on Mountain Lion with the latest Java release.
>>>>>>>>>>>
>>>>>>>>>>> mrg
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> On Tue, Jul 9, 2013 at 8:16 PM, Aristedes Maniatis
>>>>>>>>>>> <ari@maniatis.org<javascript:;>>
>>>>>>>>>
>>>>>>>>> wrote:
>>>>>>>>>>>>
>>>>>>>>>>>> On 10/07/13 9:04am, Gavin McDonald wrote:
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> It is now non optional and for your release
to hit the mirrors you
>>>>>>>>>
>>>>>>>>> must
>>>>>>>>>>>>>
>>>>>>>>>>>>> commit
>>>>>>>>>>>>> your approved release to the above release
area.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> https://issues.apache.org/jira/browse/INFRA-6537
>>>>>>>>>>>>
>>>>>>>>>>>> Thanks
>>>>>>>>>>>> Ari
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> --
>>>>>>>>>>>> -------------------------->
>>>>>>>>>>>> Aristedes Maniatis
>>>>>>>>>>>> GPG fingerprint CBFB 84B4 738D 4E87 5E5C
 5EFA EF6A 7D2E 3E49 102A
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>
>>>>>>
>>>>>> --
>>>>>> -------------------------->
>>>>>> Aristedes Maniatis
>>>>>> GPG fingerprint CBFB 84B4 738D 4E87 5E5C  5EFA EF6A 7D2E 3E49 102A
>>>>>
>>>>
>>>>
>>>
>>
>

Mime
View raw message