cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <>
Subject Re: SQLSelect: Getting fluent… WDYT?
Date Sun, 26 May 2013 19:48:34 GMT

On May 26, 2013, at 9:31 PM, Michael Gentry <> wrote:

> Also, the three selects I mentioned are: SQLSelect[1].query(Artist.class,
> "SELECT[2] * FROM Artists").select[3](context).  That just seems like too
> many selects to me, which is why I was suggesting alternatives.

Good point about 3 selects. I am all for providing select clause builder, appending columns,
etc. to eliminate #2.

I guess the only reason for select #3 is to be symmetrical with the new
method (as this is what is being called ultimately). Other than that I don't have objections
for renaming it to "fetch". Also we have "selectOne"… I guess that would be "fetchOne" or


View raw message