cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tore Halset <hal...@pvv.ntnu.no>
Subject Re: [jira] [Commented] (CAY-1688) [PATCH] rename DataDomain.getNode to getDataNode
Date Thu, 23 Aug 2012 09:28:50 GMT
Hi.

Okay, that is fine. I deleted the comment.

 - Tore.

On Aug 23, 2012, at 11:05 , Andrus Adamchik wrote:

> Hi Tore,
> 
> Trunk is 3.2 which will presumably be released in more than a year, so all the previously
deprecated stuff was removed on trunk per CAY-1718. This is consistent with our past deprecation
policies. But we can discuss a change to that.
> 
> Andrus
> 
> 
> 
> On Aug 23, 2012, at 11:51 AM, Tore Halset (JIRA) wrote:
>> 
>>   [ https://issues.apache.org/jira/browse/CAY-1688?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13440139#comment-13440139
] 
>> 
>> Tore Halset commented on CAY-1688:
>> ----------------------------------
>> 
>> The old getNode is gone in trunk and getNodeName was added in 3.1. Could we keep
getNode (as deprecated) a bit longer? Just to make it a bit simpler going back/forward between
cayenne versions.
>> 
>>> [PATCH] rename DataDomain.getNode to getDataNode
>>> ------------------------------------------------
>>> 
>>>               Key: CAY-1688
>>>               URL: https://issues.apache.org/jira/browse/CAY-1688
>>>           Project: Cayenne
>>>        Issue Type: Improvement
>>>        Components: Core Library
>>>  Affects Versions: 3.1M3
>>>          Reporter: John Huss
>>>          Priority: Trivial
>>>            Labels: patch
>>>           Fix For: 3.1B1
>>> 
>>>       Attachments: getDataNode_patch.txt
>>> 
>>> Original Estimate: 10m
>>> Remaining Estimate: 10m
>>> 
>>> "DataDomain.getNode(String nodeName)" should be called getDataNode instead for
better consistency and discoverability.
>> 
>> --
>> This message is automatically generated by JIRA.
>> If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
>> For more information on JIRA, see: http://www.atlassian.com/software/jira
>> 
>> 
>> 
> 
> 


Mime
View raw message