cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Gentry <mgen...@masslight.net>
Subject Re: Can we drop Java 1.5 support in Cayenne 3.2?
Date Mon, 09 Jul 2012 12:01:56 GMT
I thought this discussion was about dropping support for 1.5, not for 1.6?

I suppose there could be some issues with OS X users still on Tiger
(or older), but that OS is several generations old at this point.

On Mon, Jul 9, 2012 at 12:42 AM, Aristedes Maniatis <ari@maniatis.org> wrote:
> On 7/07/12 12:45am, Michael Gentry wrote:
>>
>> I'm OK with going to Java 1.6.
>>
>> As for the Mac OS concerns, Java 1.6 is available pre-OS X 10.7, plus
>> developers need to be cognizant of their deployment environments when
>> choosing frameworks, so I don't see that as a huge issue.
>
>
> Yes, for 95% of developers, who mostly now work in the cloud, they control
> the deployment environment absolutely. For those of us who write bits of
> software for people to download and install, you have to cope with the
> inevitable "the previous version worked, why doesn't this one?".
>
> I am still waiting to see how the OSX Java environment works out, since that
> is really the only problem area. I don't see any clear indications as to
> whether Java 7 will be backported to OSX 10.6. Or what the update mechanism
> will be for users. Or what the Swing L&F will be. Did Apple donate their
> Java UI extensions back to the openjdk project?
>
>
>
> Ari
>
>
>
>
> --
> -------------------------->
> Aristedes Maniatis
> GPG fingerprint CBFB 84B4 738D 4E87 5E5C  5EFA EF6A 7D2E 3E49 102A
>
>

Mime
View raw message